Can't select a startup action #581

Closed
Jeff0S opened this Issue Jul 8, 2014 · 7 comments

Projects

None yet

1 participant

@Jeff0S
Collaborator
Jeff0S commented Jul 8, 2014

From hooey...@gmail.com on June 06, 2013 05:32:55

What steps will reproduce the problem? - Select SWS/S&M: Set project startup action

  • The dialog to select an action appears
  • I'm unable to select an action from the action list. None of them are selectable and there's no highlight on the action when I click on one. What is the expected output? What do you see instead? - I expect to be able to select an action to set as the project startup action.

What version of SWS extension are you using? (Extensions -> About SWS...)

  • 2.3.0 Build 13 What is your Reaper version number and CPU architecture (e.g. Reaper 3.75 x64)? - REAPER v4.5rc1/x64 What operating system are you running? (e.g. Windows XP/7, OSX 10.5.8 etc, 64bit?) Windows 7 64 bit

Thanks-

-Susan

Original issue: http://code.google.com/p/sws-extension/issues/detail?id=581

@Jeff0S
Collaborator
Jeff0S commented Jul 8, 2014

From musicbynumbers@gmail.com on June 06, 2013 06:03:57

Although I'm not a programmer (or associated with the sws team), have you tried with sws build 17 as that's the latest one. :) it might be fixed in that version. hopefully!

@Jeff0S
Collaborator
Jeff0S commented Jul 8, 2014

From hooey...@gmail.com on June 06, 2013 08:07:59

Hi-

Great, it works again! Thanks! It was working here in March with an earlier version, so maybe there was something else going on. At any rate, I'm up to date now and all's well.

Thanks again-

-Susan

@Jeff0S
Collaborator
Jeff0S commented Jul 8, 2014

From swstim on June 06, 2013 11:05:46

Good to hear it's working, thanks MBN and Susan!

Status: NoChanges

@Jeff0S
Collaborator
Jeff0S commented Jul 8, 2014

From jeffos...@gmail.com on June 06, 2013 13:53:41

well, there are 2 bugs:

  1. on windows, Susan's bug is there when the Actions window is docked (can't indeed select an action since the prompt dialog box is modal)
  2. on osx, "modality" is not the same => this is not working at all (yes, impossible to define a startup action :/)

Fixed in r1083 but had to change things a bit: in the next release, the action "SWS/S&M: Set project startup action" will now prompt for a command ID or an identifier string (to copy those, right-click in the Actions window > Copy selected action CmdID/identifier string)

Owner: jeffos...@gmail.com

@Jeff0S
Collaborator
Jeff0S commented Jul 8, 2014

From jeffos...@gmail.com on June 06, 2013 13:54:39

.. thanks for the report Susan!

@Jeff0S
Collaborator
Jeff0S commented Jul 8, 2014

From hooey...@gmail.com on June 06, 2013 23:29:29

You're very welcome! And thank you for the quick fix.

@Jeff0S
Collaborator
Jeff0S commented Jul 8, 2014

From jeffos...@gmail.com on June 25, 2013 08:48:00

Status: Fixed

@Jeff0S Jeff0S closed this Jul 8, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment