Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Sws extension take Fx big #938

Closed
svijayrathinam opened this issue Dec 18, 2017 · 13 comments
Closed

Sws extension take Fx big #938

svijayrathinam opened this issue Dec 18, 2017 · 13 comments

Comments

@svijayrathinam
Copy link

@svijayrathinam svijayrathinam commented Dec 18, 2017

Hi,

I found an issue with the copy pasting of take fx with SWS extension.

Scenario : I have an "X" media item where I have a 6 in 6 out plugin as take fx. I have a "y" media item with no plugins. Now I want to copy the plugins from the "X" item to "Y" clip item.

For this I use these shortcuts.

SWS/S&M: Copy FX Chain (Depending on Focus)

and then

SWS/S&M: Paste FX Chain (Depending on Focus)

When I do this the "Y" media item only has 2in6 out in the plugin pin configuration. Then I have to manually open the plugin and then modify the plugin I/O config to 6 in 6 out.

But if I just cmd drag and drop the take fx from "X" item to "Y" item then I dont have this problem. This is why I am sure that this is a SWS extension bug.

Can you pls fix this ?
svijayrathinam is online now Report Post

@nofishonfriday
Copy link
Collaborator

@nofishonfriday nofishonfriday commented Dec 20, 2017

Hi,

asking just in case, have you tried pressing Play after you've pasted the FX chain ?
Here at least when I do the above steps it also pastes with 2 In/X Out as you say, but it updates the In configuartion to 6 automatically when I press Play.

Alt Text

@svijayrathinam
Copy link
Author

@svijayrathinam svijayrathinam commented Dec 21, 2017

Yes.. I have tried that..This doesn't happen to me...Check the below Link

https://drive.google.com/file/d/11pG2HUftlQsHeVnH1T7HdtEzJ9E3Oa2b/view?usp=sharing

nofishonfriday added a commit to nofishonfriday/sws that referenced this issue Dec 23, 2017
@nofishonfriday
Copy link
Collaborator

@nofishonfriday nofishonfriday commented Dec 24, 2017

Thanks for the screencapture.
Could you please test with the version linked below and let us know if it works for you ?
(I don't have the plugin you're using, so I can't test with it here.)

https://www.dropbox.com/s/r9y1xobok16mw9u/sws_osx.dmg?dl=1

Note:
It's a version only meant for testing, so don't forget to reinstall the current official SWS version afterwards.

Thanks.

@svijayrathinam
Copy link
Author

@svijayrathinam svijayrathinam commented Dec 24, 2017

Hi Thank you very much for your work. I tried this. But the problem is still there. If you want the plugin you can download the trial here

http://www.iosono-sound.com/vstaax-plug-ins/

Its not just with this plugin but with every plugin.

@nofishonfriday
Copy link
Collaborator

@nofishonfriday nofishonfriday commented Dec 24, 2017

Ah, I almost missed it in the screencapture, you have a default preset set for the plugin, this means the correct channel assigment is done automatically when inserting the plugin, right ?

Not sure yet, but seems to me what's happening is that the the default preset (and thus the channel assignment) is not propagated when copy / pasting via the SWS actions. I'll try to investigate further.

(As always, help from other SWS collaborators appreciated).

@svijayrathinam
Copy link
Author

@svijayrathinam svijayrathinam commented Jan 8, 2018

Yes. It works with the test version now..Sorry I didn't install the test version in the right folder. When will this be released officially Pls ?

@nofishonfriday
Copy link
Collaborator

@nofishonfriday nofishonfriday commented Jan 10, 2018

Thanks for testing and reporting back, good to know it also works for you.
I'm hoping a fix will be in the next official SWS version but I don't know currently when this will be.

@svijayrathinam
Copy link
Author

@svijayrathinam svijayrathinam commented Jan 19, 2018

Hello, Problem again..But now in a different form...The same bug is back on version 5.71 Pre13icc version. Here is the link. Pls help

https://www.dropbox.com/s/3zayw4x1yfurncv/Take%20FX%20Copy%20and%20Paste%20bug%20on%20multichannel%20Plugins.mov?dl=0

@svijayrathinam
Copy link
Author

@svijayrathinam svijayrathinam commented Jan 26, 2018

Any Update on this pls ?

@nofishonfriday
Copy link
Collaborator

@nofishonfriday nofishonfriday commented Jan 29, 2018

edit:
I see schwa has replied to your issue.
https://forum.cockos.com/showpost.php?p=1946908&postcount=28

So it seems the new issue is a bug in the plugin not on SWS I think.

@nofishonfriday
Copy link
Collaborator

@nofishonfriday nofishonfriday commented Feb 4, 2018

@devs

The original issue (as I understand) is that the TAKEFX_NCH line is not part of the TAKEFX chunk and so doesn't get copied via 'SWS/S&M: Copy FX Chain (Depending on Focus)' resulting in setting the pasted take FX chain back to 2 channels.

takefx_nch

My patch seems to fix (also confirmed by OP above) but I'm hesitant submitting as PR because of risk of corrupting projects (when modifying chunk) so I'd appreciate review / help.

Would probably better to fix directly in SNM_FXChainTakePatcher but I don't understand good enough to do that.

@nofishonfriday
Copy link
Collaborator

@nofishonfriday nofishonfriday commented Mar 12, 2018

Justin says it's ok..
https://askjf.com/index.php?q=4041s

@svijayrathinam
Copy link
Author

@svijayrathinam svijayrathinam commented Jun 8, 2018

Hi This take fx channel bug is still not fixed in ver 2.9.8.

Can you pls fix this ?

I reported this long time ago and nofish made a temporary fix. But Now I find new feautures in SWS extension ver 2.9.8 that I want to use. But the old bug still remains..Can you pls fix this ? if not..@nofish could you pls make another temporary fix with the new version ?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants