Upgrade script does not work with slim releases yet #202

Open
shino opened this Issue Dec 20, 2013 · 1 comment

Projects

None yet

4 participants

Contributor
shino commented Dec 20, 2013

Gleaning issue from #52 .

Upgrading with slim release can be done if we do it manually.

  1. unpack relup archive manually
  2. copy releases directory and necessary libraries
  3. using release_hander:set_unpacked/2 .

Slim release is a experimental feature of reltool and release_handler does not know
about it at all (at least R16B03). So relup archive includes erts and all libraries in OTP,
we need to select necessary libraries in step 2,
(These steps are illustrated at https://github.com/shino/slim-upgrade-sample )

These steps might possibly be automated by slim-release-aware
install_upgrade escript.

@tsloughter tsloughter closed this Jun 15, 2014
Contributor
tuncer commented Jun 15, 2014

@tsloughter why did you close this? This is a TODO ticket.

@ferd ferd added the enhancement label Jun 15, 2014
@ferd ferd reopened this Jun 15, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment