Permalink
Browse files

Moving check for PHP version to occur only in DEVELOPMENT mode.

  • Loading branch information...
KrisJordan committed Sep 29, 2009
1 parent ea0fec3 commit 98cb76256c9d7b3de6192e46ed0c0d172e5e6b4e
Showing with 6 additions and 6 deletions.
  1. +6 −6 bootstrap.php
View
@@ -58,8 +58,13 @@
public static $policy;
static function init() {
- if(self::$mode == self::PRODUCTION) {
+ if(self::$mode === self::PRODUCTION) {
self::$useTurboSpeed = true;
+ } else {
+ list($major,$minor,$revision) = explode('.',phpversion());
+ if(!((int)$major >= 5 && (int)$minor >= 2)) {
+ die('Recess requires PHP version 5.2.4 or greater.');
+ }
}
$_ENV['dir.recess'] = self::$recessDir;
@@ -111,11 +116,6 @@ static function init() {
$message .= '<ul>';
$pdoMessages = array();
- list($major,$minor,$revision) = explode('.',phpversion());
- if(!((int)$major >= 5 && (int)$minor >= 2)) {
- $pdoMessages[] = 'PHP version 5.2 or greater is required';
- }
-
if(!extension_loaded('PDO')) {
$pdoMessages[] = 'Install PHP\'s PDO Extension';
$pdoMessages[] = 'Install Sqlite or MySQL PDO Driver';

0 comments on commit 98cb762

Please sign in to comment.