Skip to content
Browse files

Checking for PHP version in install process.

  • Loading branch information...
1 parent 83673d3 commit ea0fec3b822f2284cd13fc653fef69d4b34aa5b4 @KrisJordan KrisJordan committed
Showing with 6 additions and 0 deletions.
  1. +6 −0 bootstrap.php
View
6 bootstrap.php
@@ -110,6 +110,12 @@ static function init() {
$message .= '<strong>Next Step(s):</strong>';
$message .= '<ul>';
$pdoMessages = array();
+
+ list($major,$minor,$revision) = explode('.',phpversion());
+ if(!((int)$major >= 5 && (int)$minor >= 2)) {
+ $pdoMessages[] = 'PHP version 5.2 or greater is required';
+ }
+
if(!extension_loaded('PDO')) {
$pdoMessages[] = 'Install PHP\'s PDO Extension';
$pdoMessages[] = 'Install Sqlite or MySQL PDO Driver';

0 comments on commit ea0fec3

Please sign in to comment.
Something went wrong with that request. Please try again.