Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Rails - Yaw doesn't reset when removing "follow-yaw" flag #1026

Open
Jigoku opened this issue Mar 5, 2020 · 0 comments
Open

Rails - Yaw doesn't reset when removing "follow-yaw" flag #1026

Jigoku opened this issue Mar 5, 2020 · 0 comments
Labels

Comments

@Jigoku
Copy link
Member

@Jigoku Jigoku commented Mar 5, 2020

If you set "follow-yaw" to a mapmodel rail, then remove the "follow-yaw" flag, the model stays at the last rotated position (doesn't reflect the actual yaw value set on the map model).

In editing;

  • Create several linked rails with;
    /newent rail 1000 31

  • Link a mapmodel to the rail (with yaw 0)

  • Mapmodel rotates with follow-yaw / spline set as expected

  • Change the rail flags to remove follow-yaw
    /entattr 1 20

  • Mapmodel's yaw is still offset to last interpolated position, despite yaw attr being set to 0

Only way to reset this is to reload the map.

@triage-new-issues triage-new-issues bot added the triage label Mar 5, 2020
@Jigoku Jigoku added the status: bug label Mar 5, 2020
@triage-new-issues triage-new-issues bot removed the triage label Mar 5, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.