Permalink
Browse files

Merge branch 'master' of git://github.com/xaviershay/enki

Conflicts:
	lib/enki/config.rb
	spec/be_valid_xhtml.rb
  • Loading branch information...
redinger committed Sep 6, 2009
2 parents d2d9e47 + 26ac458 commit 7bc62aac175b4ea8411588a6f2158c1e4b315517
Showing with 10 additions and 6 deletions.
  1. +5 −0 README.textile
  2. +2 −2 config/environment.rb
  3. +1 −1 config/environments/test.rb
  4. +1 −0 lib/enki/config.rb
  5. +1 −3 spec/be_valid_xhtml.rb
View
@@ -11,6 +11,11 @@ h2. Quick Start
git checkout -b myblog # Create a new work branch
cp config/database.example.yml config/database.yml
# Edit config/enki.yml and config/database.yml to taste
+
+ # Next step needs libxml2 and libxslt1 and their headers
+ # On Debian-based systems: apt-get install libxml2-dev libxslt1-dev
+ # On Mac OS X: no action required
+
rake db:migrate
rake spec
./script/server
View
@@ -15,12 +15,12 @@
# config.load_paths += %W( #{RAILS_ROOT}/extras )
# Specify gems that this application depends on and have them installed with rake gems:install
- config.gem "RedCloth", :lib => "redcloth", :version => "~> 4.1.0"
+ config.gem "RedCloth", :lib => "redcloth", :version => "~> 4.0"
config.gem "ruby-openid", :lib => "openid", :version => "~> 2.1.0"
config.gem "chronic", :version => "~> 0.2.0"
config.gem "coderay", :version => "~> 0.8.0"
config.gem "lesstile", :version => "~> 0.3"
- config.gem "mislav-will_paginate", :lib => "will_paginate", :version => "~> 2.3"
+ config.gem "mislav-will_paginate", :lib => "will_paginate", :version => "~> 2.3", :source => 'http://gems.github.com'
# Only load the plugins named here, in the order given (default is alphabetical).
# :all can be used as a placeholder for all plugins not explicitly named
@@ -26,4 +26,4 @@
config.gem "aslakhellesoy-webrat", :lib => "webrat", :version => "~> 0.3", :source => "http://gems.github.com"
config.gem "thoughtbot-factory_girl", :lib => false, :version => "~> 1.2.0", :source => "http://gems.github.com"
config.gem "rspec", :lib => false, :version => ">= 1.2.0"
-config.gem "rspec-rails", :lib => false, :version => ">= 1.2.0"
+config.gem "rspec-rails", :lib => false, :version => ">= 1.2.0"
View
@@ -1,4 +1,5 @@
require 'delegate'
+
module Enki
class Config < SimpleDelegator
def initialize(file_name)
View
@@ -1,8 +1,6 @@
# Paste me into spec_helper.rb, or save me somewhere else and require me in.
class BeValidXhtml
- # require 'action_controller/test_process'
- # require 'test/unit'
require 'net/http'
require 'digest/md5'
require 'fileutils'
@@ -122,7 +120,7 @@ def cache_resource(base,resource,extension,fn)
filename = base_filename + extension
parent_dir = File.dirname(filename)
- File.makedirs(parent_dir) unless File.exists?(parent_dir)
+ FileUtils.mkdir_p(parent_dir) unless File.exists?(parent_dir)
File.open(filename, 'r') do |f|
file_md5 = MD5.md5(f.read(f.stat.size)).to_s

0 comments on commit 7bc62aa

Please sign in to comment.