Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

require 'ostruct' used for configuration. Bumped version to 0.3.1.

git-svn-id: http://valirefl.rubyforge.org/svn/validation_reflection/trunk@15 355ff614-fa1a-0410-b54d-97652ed5f502
  • Loading branch information...
commit 2f3ce654ceb4fb40aded9d61cfc576e53858a46e 1 parent c339390
mschuerig authored
24 CHANGELOG
View
@@ -0,0 +1,24 @@
+
+== 0.3.1, 2008-01-03
+* require 'ostruct'; thanks to Georg Friedrich.
+
+== 0.3, 2008-01-01
+* Added configurability in config/plugins/validation_reflection.rb
+
+== 0.2.1, 2006-12-28
+* Moved lib files into subfolder boiler_plate.
+
+== 0.2, 2006-08-06
+?
+
+= Deprecation Notice
+
+Version 0.1 had supplied three methods
+
+ - validates_presence_of_mandatory_content_columns
+ - validates_lengths_of_string_attributes
+ - validates_all_associated
+
+These have been removed. Please use the Enforce Schema Rules plugin instead
+
+ http://enforce-schema-rules.googlecode.com/svn/trunk/enforce_schema_rules/
24 README
View
@@ -1,6 +1,8 @@
Validation Reflection
=====================
+Version 0.3.1, 2008-01-03
+
This plugin adds reflective access to validations
- ModelClass.reflect_on_all_validations
@@ -57,28 +59,6 @@ configuration using
config.plugins = [...]
-== Changes
-=== 0.3, 2008-01-01
-Added configurability in config/plugins/validation_reflection.rb
-
-=== 0.2.1, 2006-12-28
-Moved lib files into subfolder boiler_plate.
-
-=== 0.2, 2006-08-06
-
-
-== Deprecation Notice
-
-Version 0.1 had supplied three methods
-
- - validates_presence_of_mandatory_content_columns
- - validates_lengths_of_string_attributes
- - validates_all_associated
-
-These have been removed. Please use the Enforce Schema Rules plugin instead
-
- http://enforce-schema-rules.googlecode.com/svn/trunk/enforce_schema_rules/
-
Copyright (c) 2006-2008, Michael Schuerig, michael@schuerig.de
2  about.yml
View
@@ -3,5 +3,5 @@ summary: Reflection on validations
homepage: http://rubyforge.org/projects/valirefl/validation_reflection/trunk
plugin: validation_reflection
license: MIT
-version: 0.3
+version: 0.3.1
rails_version: >= 1.1.6
1  lib/boiler_plate/validation_reflection.rb
View
@@ -23,6 +23,7 @@
require 'active_record/reflection'
+require 'ostruct'
# Based on code by Sebastian Kanthak
# See http://dev.rubyonrails.org/ticket/861
Please sign in to comment.
Something went wrong with that request. Please try again.