shinima Upgrade babel version (#1523)
* deps: update babel to latest version

* babel-config: decoratorsLegacy=true to @babel/stage-2; rename .babelrc.js to babel.config.js

* update package-lock.json

* Fix .lintstagerc. Update fixtures

* Update babel-plugin-annotate-pure-calls to ^0.3.0

* Remove @babel/preset-stage-2, add @babel/plugin-proposal-object-rest-spread

* Update babel.config.js
Latest commit dfc3861 Jul 10, 2018