Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
The PHP Interpreter
C PHP C++ Shell JavaScript Makefile Other
branch: experimental/n…

This branch is even with php:experimental/newoperator

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
Zend
ext
main
regex
scripts
tests
win32
CODING_STANDARDS
CREDITS
ChangeLog
ChangeLog.3
ChangeLog.TODO
FUNCTION_LIST.txt
INSTALL
LICENSE
MODULES_STATUS
Makefile.in
README-BCMATH
README.QNX
acconfig.h.in
acinclude.m4
apMakefile.libdir
apMakefile.tmpl
apidoc-zend.txt
apidoc.txt
build-defs.h.in
buildconf
calendar.mak
cgi_main.c
config.guess
config.sub
configure.in.in
crypt.mak
dbase.mak
dbm.mak
dlist.c
dlist.h
fhttpd.c
filepro.mak
footer
gd.mak
genif.pl
genif.sh
getopt.c
header
hyperwave.mak
imap4.mak
install-sh
ldap.mak
libphp4.module.in
ltconfig
ltmain.sh
main.h
makeall.bat
makedist
makeparser.bat
mod_php4.c
mod_php4.exp
mod_php4.h
msql.mak
msql1.mak
mtparser.bat
mysql.mak
output.c
output.h
php.ini-dist
php3_realpath.c
php3_realpath.h
php3_sprintf.c
php4.dsp
php4.dsw
php4dll.dsp
php4dllts.dsp
php4ext.dsw
php4ts.dsp
php4ts.dsw
php_custom_build.mak
php_getopt.h
request_info.c
request_info.h
setup
snmp.mak
stamp-h.in
zlib.mak

README.QNX

QNX4 Installation Notes
-----------------------

NOTE: General installation instructions are in the INSTALL file 


1. To compile and test PHP3 you have to grab, compile and install:
	- GNU dbm library or another db library;
	- GNU bison (1.25 or later; 1.25 tested);
	- GNU flex (any version supporting -o and -P options; 2.5.4 tested);
	- GNU diffutils (any version supporting -w option; 2.7 tested);

2. To use CVS version you may need also:
	- GNU CVS (1.9 tested);
	- GNU autoconf (2.12 tested);
	- GNU m4 (1.3 or later preferable; 1.4 tested);

3. To run configure define -lunix in command line:
	LDFLAGS=-lunix ./configure

4. To use Sybase SQL Anywhere define ODBC_QNX and CUSTOM_ODBC_LIBS in
	command line and run configure with --with-custom-odbc:
	CFLAGS=-DODBC_QNX LDFLAGS=-lunix CUSTOM_ODBC_LIBS="-ldblib -lodbc" ./configure --with-custom-odbc=/usr/lib/sqlany50
   If you have SQL Anywhere version 5.5.00, then you have to add 
	CFLAGS=-DSQLANY_BUG
   to workaround its SQLFreeEnv() bug. Other versions has not been tested,
   so try without this flag first.

5. To build the Apache module, you may have to hardcode an include path for 
   alloc.h in your Apache base directory:
	- APACHE_DIRECTORY/src/httpd.h: 
		change	#include "alloc.h"
		to 		#include "APACHE_DIRECTORY/src/alloc.h"
   Unless you want to use system regex library, you have to hardcode also
   a path to regex.h:
	- APACHE_DIRECTORY/src/conf.h:  
		change  #include <regex.h>
		to		#include "APACHE_DIRECTORY/src/regex/regex.h"
   I don't know so far why this required for QNX, may be it is Watcom 
   compiler problem.

  If you building Apache module with SQL Anywhere support, you'll get
  symbol conflict with BOOL. It is defined in Apache (httpd.h) and in 
  SQL Anywhere (odbc.h). This has nothing to do with PHP, so you have to 
  fix it yourself someway.

6. With above precautions, it should compile as is and pass regression
	tests completely:
		make
		make check
		make install

	Don't bother me unless you really sure you made	that all but it 
	still doesn't work.

June 28, 1998
Igor Kovalenko -- owl@infomarket.ru
Something went wrong with that request. Please try again.