Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 43 lines (32 sloc) 0.977 kb
21b19db @reset refactor engine testing scenario
reset authored
1 source "http://rubygems.org"
2
aed0b8f @reset Move gemspec method to top of file
reset authored
3 gemspec
4
616ddc5 @parndt Updated Gemfile to reduce unused dependencies.
parndt authored
5 gem 'refinerycms', '~> 2.0.10'
594dd8c @parndt Now supporting FriendlyId 4
parndt authored
6
616ddc5 @parndt Updated Gemfile to reduce unused dependencies.
parndt authored
7 gem 'quiet_assets', :group => :development
5e650f6 @ugisozols No need to use awesome_nested_set edge version anymore.
ugisozols authored
8
616ddc5 @parndt Updated Gemfile to reduce unused dependencies.
parndt authored
9 # Database Configuration
10 unless ENV['TRAVIS']
11 gem 'activerecord-jdbcsqlite3-adapter', :platform => :jruby
12 gem 'sqlite3', :platform => :ruby
13 end
1779274 @parndt Added sqlite3, pg, mysql2 to the Gemfile and added Jamie to the notif…
parndt authored
14
616ddc5 @parndt Updated Gemfile to reduce unused dependencies.
parndt authored
15 if !ENV['TRAVIS'] || ENV['DB'] == 'mysql'
16 gem 'activerecord-jdbcmysql-adapter', :platform => :jruby
17 gem 'jdbc-mysql', '= 5.1.13', :platform => :jruby
18 gem 'mysql2', :platform => :ruby
19 end
1779274 @parndt Added sqlite3, pg, mysql2 to the Gemfile and added Jamie to the notif…
parndt authored
20
616ddc5 @parndt Updated Gemfile to reduce unused dependencies.
parndt authored
21 if !ENV['TRAVIS'] || ENV['DB'] == 'postgresql'
22 gem 'activerecord-jdbcpostgresql-adapter', :platform => :jruby
23 gem 'pg', :platform => :ruby
24 end
1779274 @parndt Added sqlite3, pg, mysql2 to the Gemfile and added Jamie to the notif…
parndt authored
25
616ddc5 @parndt Updated Gemfile to reduce unused dependencies.
parndt authored
26 gem 'jruby-openssl', :platform => :jruby
9363e8d @reset Update Gemfile to what would be generated by Refinerycms
reset authored
27
616ddc5 @parndt Updated Gemfile to reduce unused dependencies.
parndt authored
28 group :test do
29 gem 'refinerycms-testing', '~> 2.0.3'
30 gem 'generator_spec', '~> 0.8.7'
eca7a1a @reset Remove spork as a development dependency
reset authored
31 end
32
616ddc5 @parndt Updated Gemfile to reduce unused dependencies.
parndt authored
33 # Gems used only for assets and not required
34 # in production environments by default.
cfba1b8 @reset Add Rails3.1 assets gemfile entry into Gemfile (required to start Rai…
reset authored
35 group :assets do
6b1fcc8 @phiggins Loosen version requirements in Gemfile.
phiggins authored
36 gem 'sass-rails'
37 gem 'coffee-rails'
cfba1b8 @reset Add Rails3.1 assets gemfile entry into Gemfile (required to start Rai…
reset authored
38 gem 'uglifier'
39 end
7ae6e14 @ugisozols Use arel 2.1.4 for now because 2.1.5 got yanked.
ugisozols authored
40
9df6580 @reset gemspec revision to support latest master branch of refinerycms
reset authored
41 gem 'jquery-rails'
adb31ed @parndt Fix 1.8.7 CI error: Gem::InstallError: nokogiri requires Ruby version…
parndt authored
42 gem 'nokogiri', '~> 1.5.0', :platforms => :mri_18
Something went wrong with that request. Please try again.