Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 45 lines (23 sloc) 1.261 kB
c38d9c3 @awagener Remove all Rails2/Rails3 checks as master is now Rails3 only
awagener authored
1 # Refinery CMS Blog
18a7089 @djones added arrows to menu, added new comments count to top level menu item…
djones authored
2
06a0ec2 @djones updated readme to explain how to enable sharethis support
djones authored
3 Simple blog engine for [Refinery CMS](http://refinerycms.com). It supports posts, categories and comments.
4
e70193c @ugisozols Update readme.
ugisozols authored
5 This version of `refinerycms-blog` supports Rails 3.1.x. To use Rails 2.3.x use the [refinerycms-blog "Rails 2.3.x stable branch"](http://github.com/resolve/refinerycms-blog/tree/rails2-stable).
c38d9c3 @awagener Remove all Rails2/Rails3 checks as master is now Rails3 only
awagener authored
6
06a0ec2 @djones updated readme to explain how to enable sharethis support
djones authored
7 Options:
8
9 * Comment moderation
10 * [ShareThis.com](http://sharethis.com) support on posts. Set your key in Refinery's settings area to enable this.
18a7089 @djones added arrows to menu, added new comments count to top level menu item…
djones authored
11
75e9940 @parndt Version 1.1 which supports Rails3 versions of RefineryCMS (1.0.1 etc …
parndt authored
12 ## Requirements
13
e70193c @ugisozols Update readme.
ugisozols authored
14 Refinery CMS version 2.0.0 or above.
75e9940 @parndt Version 1.1 which supports Rails3 versions of RefineryCMS (1.0.1 etc …
parndt authored
15
c38d9c3 @awagener Remove all Rails2/Rails3 checks as master is now Rails3 only
awagener authored
16 ## Install
b289799 @djones update formatting of readme
djones authored
17
75e9940 @parndt Version 1.1 which supports Rails3 versions of RefineryCMS (1.0.1 etc …
parndt authored
18 Open up your ``Gemfile`` and add at the bottom this line:
b289799 @djones update formatting of readme
djones authored
19
e70193c @ugisozols Update readme.
ugisozols authored
20 gem 'refinerycms-blog', '~> 2.0.0'
18a7089 @djones added arrows to menu, added new comments count to top level menu item…
djones authored
21
75e9940 @parndt Version 1.1 which supports Rails3 versions of RefineryCMS (1.0.1 etc …
parndt authored
22 Now, run ``bundle install``
18a7089 @djones added arrows to menu, added new comments count to top level menu item…
djones authored
23
75e9940 @parndt Version 1.1 which supports Rails3 versions of RefineryCMS (1.0.1 etc …
parndt authored
24 Next, to install the blog plugin run:
e5b9af1 @parndt Merged in Joe's and Steven's forks and updated for compatibility with…
parndt authored
25
e70193c @ugisozols Update readme.
ugisozols authored
26 rails generate refinery:blog
18a7089 @djones added arrows to menu, added new comments count to top level menu item…
djones authored
27
b289799 @djones update formatting of readme
djones authored
28 Finally migrate your database and you're done.
18a7089 @djones added arrows to menu, added new comments count to top level menu item…
djones authored
29
21b19db @reset refactor engine testing scenario
reset authored
30 rake db:migrate
31
32 ## Developing & Contributing
33
5e24eeb @reset Update README with additional development instructions
reset authored
34 The version of Refinery to develop this engine against is defined in the gemspec. To override the version of refinery to develop against, edit the project Gemfile to point to a local path containing a clone of refinerycms.
35
21b19db @reset refactor engine testing scenario
reset authored
36 ### Testing
37
38 Setup the test environment
39
87f478e @reset Update testing setup task to reflect new namespace
reset authored
40 $ bundle exec rake refinery:testing:engine:setup
21b19db @reset refactor engine testing scenario
reset authored
41
42 Run the test suite with [Guard](https://github.com/guard/guard)
43
44 $ bundle exec guard start
45
Something went wrong with that request. Please try again.