RecordNotFound in Refinery::Blog::PostsController #365

Closed
scottolsen opened this Issue Dec 18, 2013 · 1 comment

3 participants

@scottolsen

I created a new refinery project and added the refinerycms-blog engine. I am able to create blog posts but I can't edit or view them.

I'm using:

ruby 2.0
rails 3.2.16
refinerycms 2.1.1 
refinerycms-blog 2.1.0

Here is the error

Couldn't find Refinery::Blog::Post with id=foo [WHERE "refinery_blog_post_translations"."locale" = 'en']
@yosiyuki

I think it's same issue with #361 , please check #363 as well.

@parndt parndt closed this Aug 24, 2014
@prokopsimek prokopsimek added a commit that referenced this issue Dec 9, 2014
@prokopsimek prokopsimek bugfix
Fixes: #367
Maybe fixes: #361 #363 #365 #342

HOW TO FIX:
1) pull this fix
2) Start rails console (rails c)
3) In rails console run command:  ::Refinery::Blog::Post.find_each(&:save)

And it should be ok. It is for me...
d927ea8
@prokopsimek prokopsimek referenced this issue Dec 9, 2014
Closed

bugfix #404

@prokopsimek prokopsimek added a commit that referenced this issue Dec 9, 2014
@prokopsimek prokopsimek bugfix
Fixes: #367
Maybe fixes: #361 #363 #365 #342

HOW TO FIX:
1) pull this fix
2) Start rails console (rails c)
3) In rails console run command:  ::Refinery::Blog::Post.find_each(&:save)

And it should be ok. It is for me...
3f1b663
@prokopsimek prokopsimek added a commit that referenced this issue Dec 9, 2014
@prokopsimek prokopsimek bugfix
Fixes: #367
Maybe fixes: #361 #363 #365 #342

HOW TO FIX:
1) pull this fix
2) Start rails console (rails c)
3) In rails console run command:  ::Refinery::Blog::Post.find_each(&:save)

And it should be ok. It is for me...
b57eebc
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment