Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 56 lines (44 sloc) 1.326 kb
a7a149c @ugisozols Remove unused gems from Gemfile. Allow additional gems to be specified i...
ugisozols authored
1 source 'https://rubygems.org'
368a1e1 @ugisozols Make usable with Refinery CMS 2.0.0.
ugisozols authored
2
3 gemspec
4
a7a149c @ugisozols Remove unused gems from Gemfile. Allow additional gems to be specified i...
ugisozols authored
5 gem 'refinerycms', '~> 2.1.0'
6 gem 'refinerycms-acts-as-indexed', '~> 1.0.0'
368a1e1 @ugisozols Make usable with Refinery CMS 2.0.0.
ugisozols authored
7
e027bbc @parndt Add proper dependency to refinerycms-core 2.1.0 and refinerycms-acts-as-...
parndt authored
8 group :development, :test do
9 gem 'refinerycms-testing', '~> 2.1.0'
10 gem 'poltergeist'
11
12 platforms :jruby do
13 gem 'activerecord-jdbcsqlite3-adapter'
14 gem 'activerecord-jdbcmysql-adapter'
15 gem 'activerecord-jdbcpostgresql-adapter'
16 gem 'jruby-openssl'
17 end
18
19 unless defined?(JRUBY_VERSION)
20 gem 'sqlite3'
21 gem 'mysql2'
22 gem 'pg'
23 end
0d6cafc @parndt Fix diff line in Gemfile.
parndt authored
24 end
368a1e1 @ugisozols Make usable with Refinery CMS 2.0.0.
ugisozols authored
25
a7a149c @ugisozols Remove unused gems from Gemfile. Allow additional gems to be specified i...
ugisozols authored
26 # Database Configuration
27 unless ENV['TRAVIS']
28 gem 'activerecord-jdbcsqlite3-adapter', :platform => :jruby
29 gem 'sqlite3', :platform => :ruby
30 end
368a1e1 @ugisozols Make usable with Refinery CMS 2.0.0.
ugisozols authored
31
a7a149c @ugisozols Remove unused gems from Gemfile. Allow additional gems to be specified i...
ugisozols authored
32 if !ENV['TRAVIS'] || ENV['DB'] == 'mysql'
33 gem 'activerecord-jdbcmysql-adapter', :platform => :jruby
34 gem 'jdbc-mysql', '= 5.1.13', :platform => :jruby
35 gem 'mysql2', :platform => :ruby
36 end
368a1e1 @ugisozols Make usable with Refinery CMS 2.0.0.
ugisozols authored
37
a7a149c @ugisozols Remove unused gems from Gemfile. Allow additional gems to be specified i...
ugisozols authored
38 if !ENV['TRAVIS'] || ENV['DB'] == 'postgresql'
39 gem 'activerecord-jdbcpostgresql-adapter', :platform => :jruby
40 gem 'pg', :platform => :ruby
368a1e1 @ugisozols Make usable with Refinery CMS 2.0.0.
ugisozols authored
41 end
42
a7a149c @ugisozols Remove unused gems from Gemfile. Allow additional gems to be specified i...
ugisozols authored
43 gem 'jruby-openssl', :platform => :jruby
44
368a1e1 @ugisozols Make usable with Refinery CMS 2.0.0.
ugisozols authored
45 # Refinery/rails should pull in the proper versions of these
46 group :assets do
47 gem 'sass-rails'
48 gem 'coffee-rails'
49 gem 'uglifier'
50 end
51
a7a149c @ugisozols Remove unused gems from Gemfile. Allow additional gems to be specified i...
ugisozols authored
52 # Load local gems according to Refinery developer preference.
53 if File.exist? local_gemfile = File.expand_path('../.gemfile', __FILE__)
54 eval File.read(local_gemfile)
55 end
Something went wrong with that request. Please try again.