Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 70 lines (58 sloc) 1.476 kb
368a1e1 @ugisozols Make usable with Refinery CMS 2.0.0.
ugisozols authored
1 source 'http://rubygems.org'
2
3 gemspec
4
87704d7 @ugisozols Update dependencies and use 2.0.0.
ugisozols authored
5 gem 'refinerycms', '~> 2.0.0'
368a1e1 @ugisozols Make usable with Refinery CMS 2.0.0.
ugisozols authored
6
7 group :development, :test do
87704d7 @ugisozols Update dependencies and use 2.0.0.
ugisozols authored
8 gem 'refinerycms-testing', '~> 2.0.0'
7d14d18 @ugisozols Add Guard support.
ugisozols authored
9 gem 'guard-rspec', '~> 0.6.0'
87704d7 @ugisozols Update dependencies and use 2.0.0.
ugisozols authored
10
368a1e1 @ugisozols Make usable with Refinery CMS 2.0.0.
ugisozols authored
11 platforms :jruby do
12 gem 'activerecord-jdbcsqlite3-adapter'
13 gem 'activerecord-jdbcmysql-adapter'
14 gem 'activerecord-jdbcpostgresql-adapter'
15 gem 'jruby-openssl'
16 end
17
18 unless defined?(JRUBY_VERSION)
19 gem 'sqlite3'
20 gem 'mysql2'
21 gem 'pg'
22 end
23
24 platforms :mswin, :mingw do
25 gem 'win32console'
26 gem 'rb-fchange', '~> 0.0.5'
27 gem 'rb-notifu', '~> 0.0.4'
28 end
29
30 platforms :ruby do
7d14d18 @ugisozols Add Guard support.
ugisozols authored
31 gem 'spork', '~> 0.9.0.rc'
368a1e1 @ugisozols Make usable with Refinery CMS 2.0.0.
ugisozols authored
32 gem 'guard-spork'
33
34 unless ENV['TRAVIS']
7d14d18 @ugisozols Add Guard support.
ugisozols authored
35 require 'rbconfig'
368a1e1 @ugisozols Make usable with Refinery CMS 2.0.0.
ugisozols authored
36 if RbConfig::CONFIG['target_os'] =~ /darwin/i
37 gem 'rb-fsevent', '>= 0.3.9'
7d14d18 @ugisozols Add Guard support.
ugisozols authored
38 gem 'ruby_gntp'
368a1e1 @ugisozols Make usable with Refinery CMS 2.0.0.
ugisozols authored
39 end
40 if RbConfig::CONFIG['target_os'] =~ /linux/i
41 gem 'rb-inotify', '>= 0.5.1'
42 gem 'libnotify', '~> 0.1.3'
43 gem 'therubyracer', '~> 0.9.9'
44 end
45 end
46 end
47
48 platforms :jruby do
49 unless ENV['TRAVIS']
7d14d18 @ugisozols Add Guard support.
ugisozols authored
50 require 'rbconfig'
368a1e1 @ugisozols Make usable with Refinery CMS 2.0.0.
ugisozols authored
51 if RbConfig::CONFIG['target_os'] =~ /darwin/i
7d14d18 @ugisozols Add Guard support.
ugisozols authored
52 gem 'ruby_gntp'
368a1e1 @ugisozols Make usable with Refinery CMS 2.0.0.
ugisozols authored
53 end
54 if RbConfig::CONFIG['target_os'] =~ /linux/i
55 gem 'rb-inotify', '>= 0.5.1'
56 gem 'libnotify', '~> 0.1.3'
57 end
58 end
59 end
60 end
61
62 # Refinery/rails should pull in the proper versions of these
63 group :assets do
64 gem 'sass-rails'
65 gem 'coffee-rails'
66 gem 'uglifier'
67 end
68
69 gem 'jquery-rails'
Something went wrong with that request. Please try again.