Permalink
Browse files

Update Travis CI config.

- don't test Ruby 1.8.7 because we dropped support for it
- don't test 1.8 modes for JRuby and Rubinius
- test Ruby 2.0.0
- don't install gems from development group
  • Loading branch information...
ugisozols committed Jun 3, 2013
1 parent 1e81a34 commit bb48634caaefc09e3f2f5336c00b00e6ec5add9c
Showing with 3 additions and 5 deletions.
  1. +3 −5 .travis.yml
View
@@ -1,6 +1,9 @@
language: ruby
before_install:
- 'if [[ "$TRAVIS_RUBY_VERSION" =~ "jruby" ]] ; then gem update --system ; fi'
+ - gem install bundler
+install:
+ - bundle install --without development
before_script:
- "bundle exec rake refinery:testing:dummy_app > /dev/null"
script:
@@ -22,15 +25,10 @@ env:
- DB=mysql
matrix:
allow_failures:
- - rvm: rbx-18mode
- rvm: rbx-19mode
- rvm: jruby-19mode
- - rvm: jruby-18mode
rvm:
- 2.0
- 1.9.3
- - 1.8.7
- rbx-19mode
- jruby-19mode
- - rbx-18mode
- - jruby-18mode

0 comments on commit bb48634

Please sign in to comment.