Permalink
Browse files

Merged in branch rails-3-1 to master, now we're headed to version 1.1…

…. For 1.0.x see branch 1-0-stable.
  • Loading branch information...
2 parents 892d4f8 + dcf5f1c commit 25fad3987a4694a1fdc22dcffda4da1ea99a0792 @parndt parndt committed May 28, 2011
Showing 349 changed files with 3,989 additions and 3,142 deletions.
View
@@ -2,14 +2,18 @@ source 'http://rubygems.org'
gemspec
+gem 'rails'
+gem "rack"#, :git => "git://github.com/rack/rack.git"
+gem "arel"#, :git => "https://github.com/rails/arel.git"
+gem 'friendly_id_globalize3'#, :path => "../tmp/friendly_id"
# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails'
if RUBY_PLATFORM == 'java'
gem 'activerecord-jdbcsqlite3-adapter', '>= 1.0.2', :platform => :jruby
else
gem 'sqlite3'
- gem 'mysql2', '~> 0.2.7'
+ gem 'mysql2'
end
# Use unicorn as the web server
@@ -20,23 +24,23 @@ end
# gem 'capistrano'
# To use debugger
-# gem 'ruby-debug'
+gem 'ruby-debug', :platform => :mri_18
# or in 1.9.x:
-# gem 'ruby-debug19'
+gem 'ruby-debug19', :platform => :mri_19
# For Heroku/s3:
# gem 'fog'
# REFINERY CMS ================================================================
# Anything you put in here will be overridden when the app gets updated.
-# gem 'refinerycms', '~> 1.0.0'
+# gem 'refinerycms', '~> 1.1.0'
group :development, :test do
# To use refinerycms-testing, uncomment it (if it's commented out) and run 'bundle install'
# Then, run 'rails generate refinerycms_testing' which will copy its support files.
# Finally, run 'rake' to run the tests.
- gem 'refinerycms-testing', '~> 1.0.0'
+ gem 'refinerycms-testing', '~> 1.1.0'
end
# END REFINERY CMS ============================================================
@@ -54,5 +58,7 @@ end
# gem 'refinerycms-page-images', '~> 1.0'
# Add i18n support (optional, you can remove this if you really want to).
-gem 'refinerycms-i18n', '~> 1.0.0'
+gem 'refinerycms-i18n', '~> 1.1.0',
+ :git => 'git://github.com/resolve/refinerycms-i18n',
+ :branch => 'rails-3-1'
# END USER DEFINED
View
@@ -1,51 +1,60 @@
+GIT
+ remote: git://github.com/resolve/refinerycms-i18n
+ revision: b58e013eea2dc13c8a01bdef0e37fa232ca2edbb
+ branch: rails-3-1
+ specs:
+ refinerycms-i18n (1.1.0)
+ refinerycms-core (~> 1.1.0)
+ routing-filter (>= 0.2.3)
+
PATH
remote: .
specs:
- refinerycms (1.0.0)
+ refinerycms (1.1.0)
bundler (~> 1.0)
- refinerycms-authentication (= 1.0.0)
- refinerycms-base (= 1.0.0)
- refinerycms-core (= 1.0.0)
- refinerycms-dashboard (= 1.0.0)
- refinerycms-images (= 1.0.0)
- refinerycms-pages (= 1.0.0)
- refinerycms-resources (= 1.0.0)
- refinerycms-settings (= 1.0.0)
- refinerycms-authentication (1.0.0)
+ refinerycms-authentication (= 1.1.0)
+ refinerycms-base (= 1.1.0)
+ refinerycms-core (= 1.1.0)
+ refinerycms-dashboard (= 1.1.0)
+ refinerycms-images (= 1.1.0)
+ refinerycms-pages (= 1.1.0)
+ refinerycms-resources (= 1.1.0)
+ refinerycms-settings (= 1.1.0)
+ refinerycms-authentication (1.1.0)
devise (~> 1.3.0)
friendly_id_globalize3 (~> 3.2.1)
- refinerycms-core (= 1.0.0)
- refinerycms-base (1.0.0)
- refinerycms-core (1.0.0)
+ refinerycms-core (= 1.1.0)
+ refinerycms-base (1.1.0)
+ refinerycms-core (1.1.0)
acts_as_indexed (~> 0.7)
awesome_nested_set (~> 2.0)
friendly_id_globalize3 (~> 3.2.1)
globalize3 (~> 0.1)
- rails (~> 3.0.7)
- refinerycms-base (= 1.0.0)
+ kaminari (~> 0.12)
+ rails (>= 3.1.0.rc1)
+ refinerycms-base (= 1.1.0)
refinerycms-generators (~> 1.0)
- refinerycms-settings (= 1.0.0)
+ refinerycms-settings (= 1.1.0)
truncate_html (~> 0.5)
- will_paginate (~> 3.0.pre)
- refinerycms-dashboard (1.0.0)
- refinerycms-core (= 1.0.0)
- refinerycms-images (1.0.0)
+ refinerycms-dashboard (1.1.0)
+ refinerycms-core (= 1.1.0)
+ refinerycms-images (1.1.0)
dragonfly (~> 0.9.0)
rack-cache (>= 0.5.3)
- refinerycms-core (= 1.0.0)
- refinerycms-pages (1.0.0)
+ refinerycms-core (= 1.1.0)
+ refinerycms-pages (1.1.0)
awesome_nested_set (~> 2.0)
friendly_id_globalize3 (~> 3.2.1)
globalize3 (~> 0.1)
- refinerycms-core (= 1.0.0)
+ refinerycms-core (= 1.1.0)
seo_meta (~> 1.1)
- refinerycms-resources (1.0.0)
+ refinerycms-resources (1.1.0)
dragonfly (~> 0.9.0)
rack-cache (>= 0.5.3)
- refinerycms-core (= 1.0.0)
- refinerycms-settings (1.0.0)
- refinerycms-base (= 1.0.0)
- refinerycms-testing (1.0.0)
+ refinerycms-core (= 1.1.0)
+ refinerycms-settings (1.1.0)
+ refinerycms-base (= 1.1.0)
+ refinerycms-testing (1.1.0)
autotest
autotest-notification
autotest-rails
@@ -57,44 +66,48 @@ PATH
gherkin
json_pure
launchy
- rack-test (~> 0.5.6)
+ rack-test (>= 0.5.6)
rcov
- refinerycms-core (= 1.0.0)
+ refinerycms-core (= 1.1.0)
rspec-rails (~> 2.6)
GEM
remote: http://rubygems.org/
specs:
ZenTest (4.5.0)
- abstract (1.0.0)
- actionmailer (3.0.7)
- actionpack (= 3.0.7)
- mail (~> 2.2.15)
- actionpack (3.0.7)
- activemodel (= 3.0.7)
- activesupport (= 3.0.7)
- builder (~> 2.1.2)
- erubis (~> 2.6.6)
- i18n (~> 0.5.0)
- rack (~> 1.2.1)
- rack-mount (~> 0.6.14)
- rack-test (~> 0.5.7)
- tzinfo (~> 0.3.23)
- activemodel (3.0.7)
- activesupport (= 3.0.7)
- builder (~> 2.1.2)
- i18n (~> 0.5.0)
- activerecord (3.0.7)
- activemodel (= 3.0.7)
- activesupport (= 3.0.7)
- arel (~> 2.0.2)
- tzinfo (~> 0.3.23)
- activeresource (3.0.7)
- activemodel (= 3.0.7)
- activesupport (= 3.0.7)
- activesupport (3.0.7)
+ actionmailer (3.1.0.rc1)
+ actionpack (= 3.1.0.rc1)
+ mail (~> 2.3.0)
+ actionpack (3.1.0.rc1)
+ activemodel (= 3.1.0.rc1)
+ activesupport (= 3.1.0.rc1)
+ builder (~> 3.0.0)
+ erubis (~> 2.7.0)
+ i18n (~> 0.6.0beta1)
+ rack (~> 1.3.0.beta2)
+ rack-cache (~> 1.0.1)
+ rack-mount (~> 0.8.1)
+ rack-test (~> 0.6.0)
+ sprockets (~> 2.0.0.beta.5)
+ tzinfo (~> 0.3.27)
+ activemodel (3.1.0.rc1)
+ activesupport (= 3.1.0.rc1)
+ bcrypt-ruby (~> 2.1.4)
+ builder (~> 3.0.0)
+ i18n (~> 0.6.0beta1)
+ activerecord (3.1.0.rc1)
+ activemodel (= 3.1.0.rc1)
+ activesupport (= 3.1.0.rc1)
+ arel (~> 2.1.1)
+ tzinfo (~> 0.3.27)
+ activeresource (3.1.0.rc1)
+ activemodel (= 3.1.0.rc1)
+ activesupport (= 3.1.0.rc1)
+ activesupport (3.1.0.rc1)
+ multi_json (~> 1.0)
acts_as_indexed (0.7.2)
- arel (2.0.10)
+ archive-tar-minitar (0.5.2)
+ arel (2.1.1)
autotest (4.4.6)
ZenTest (>= 4.4.1)
autotest-notification (2.3.1)
@@ -105,7 +118,7 @@ GEM
activerecord (>= 3.0.0)
babosa (0.3.4)
bcrypt-ruby (2.1.4)
- builder (2.1.2)
+ builder (3.0.0)
capybara (0.4.1.2)
celerity (>= 0.7.9)
culerity (>= 0.2.4)
@@ -118,6 +131,7 @@ GEM
celerity (0.8.9)
childprocess (0.1.9)
ffi (~> 1.0.6)
+ columnize (0.3.2)
configuration (1.2.0)
cucumber (0.10.3)
builder (>= 2.1.2)
@@ -138,8 +152,7 @@ GEM
diff-lcs (1.1.2)
dragonfly (0.9.2)
rack
- erubis (2.6.6)
- abstract (>= 1.0.0)
+ erubis (2.7.0)
factory_girl (1.3.3)
ffi (1.0.9)
friendly_id_globalize3 (3.2.1.3)
@@ -149,48 +162,54 @@ GEM
globalize3 (0.1.0)
activemodel (>= 3.0.0)
activerecord (>= 3.0.0)
- i18n (0.5.0)
+ hike (1.0.0)
+ i18n (0.6.0)
json (1.5.1)
json_pure (1.5.1)
+ kaminari (0.12.4)
+ rails (>= 3.0.0)
launchy (0.4.0)
configuration (>= 0.0.5)
rake (>= 0.8.1)
- mail (2.2.19)
- activesupport (>= 2.3.6)
+ linecache (0.43)
+ linecache19 (0.5.12)
+ ruby_core_source (>= 0.1.4)
+ mail (2.3.0)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
mime-types (1.16)
- mysql2 (0.2.7)
+ multi_json (1.0.3)
+ mysql2 (0.3.2)
nokogiri (1.4.4)
orm_adapter (0.0.5)
polyglot (0.3.1)
- rack (1.2.3)
+ rack (1.3.0)
rack-cache (1.0.2)
rack (>= 0.4)
- rack-mount (0.6.14)
+ rack-mount (0.8.1)
rack (>= 1.0.0)
- rack-test (0.5.7)
+ rack-ssl (1.3.2)
+ rack
+ rack-test (0.6.0)
rack (>= 1.0)
- rails (3.0.7)
- actionmailer (= 3.0.7)
- actionpack (= 3.0.7)
- activerecord (= 3.0.7)
- activeresource (= 3.0.7)
- activesupport (= 3.0.7)
+ rails (3.1.0.rc1)
+ actionmailer (= 3.1.0.rc1)
+ actionpack (= 3.1.0.rc1)
+ activerecord (= 3.1.0.rc1)
+ activeresource (= 3.1.0.rc1)
+ activesupport (= 3.1.0.rc1)
bundler (~> 1.0)
- railties (= 3.0.7)
- railties (3.0.7)
- actionpack (= 3.0.7)
- activesupport (= 3.0.7)
+ railties (= 3.1.0.rc1)
+ railties (3.1.0.rc1)
+ actionpack (= 3.1.0.rc1)
+ activesupport (= 3.1.0.rc1)
+ rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
- thor (~> 0.14.4)
+ thor (~> 0.14.6)
rake (0.9.0)
rcov (0.9.9)
refinerycms-generators (1.0.1)
- refinerycms-i18n (1.0.0)
- refinerycms-core (>= 0.9.9.12)
- routing-filter (>= 0.2.3)
routing-filter (0.2.3)
actionpack
rspec (2.6.0)
@@ -206,6 +225,21 @@ GEM
activesupport (~> 3.0)
railties (~> 3.0)
rspec (~> 2.6.0)
+ ruby-debug (0.10.4)
+ columnize (>= 0.1)
+ ruby-debug-base (~> 0.10.4.0)
+ ruby-debug-base (0.10.4)
+ linecache (>= 0.3)
+ ruby-debug-base19 (0.11.25)
+ columnize (>= 0.3.1)
+ linecache19 (>= 0.5.11)
+ ruby_core_source (>= 0.1.4)
+ ruby-debug19 (0.11.6)
+ columnize (>= 0.3.1)
+ linecache19 (>= 0.5.11)
+ ruby-debug-base19 (>= 0.11.19)
+ ruby_core_source (0.1.5)
+ archive-tar-minitar (>= 0.5.2)
rubyzip (0.9.4)
selenium-webdriver (0.2.0)
childprocess (>= 0.1.7)
@@ -214,25 +248,35 @@ GEM
rubyzip
seo_meta (1.1.1)
refinerycms-generators (~> 1.0.1)
+ sprockets (2.0.0.beta.8)
+ hike (~> 1.0)
+ rack (~> 1.0)
+ tilt (!= 1.3.0, ~> 1.1)
sqlite3 (1.3.3)
term-ansicolor (1.0.5)
thor (0.14.6)
+ tilt (1.3.2)
treetop (1.4.9)
polyglot (>= 0.3.1)
truncate_html (0.5.1)
tzinfo (0.3.27)
warden (1.0.4)
rack (>= 1.0)
- will_paginate (3.0.pre2)
xpath (0.1.4)
nokogiri (~> 1.3)
PLATFORMS
ruby
DEPENDENCIES
- mysql2 (~> 0.2.7)
+ arel
+ friendly_id_globalize3
+ mysql2
+ rack
+ rails
refinerycms!
- refinerycms-i18n (~> 1.0.0)
- refinerycms-testing (~> 1.0.0)
+ refinerycms-i18n (~> 1.1.0)!
+ refinerycms-testing (~> 1.1.0)
+ ruby-debug
+ ruby-debug19
sqlite3
View
@@ -4,4 +4,4 @@
require File.expand_path('../config/application', __FILE__)
require 'rake'
-RefineryApp::Application.load_tasks
+::RefineryApp::Application.load_tasks
Oops, something went wrong.

0 comments on commit 25fad39

Please sign in to comment.