Skip to content
Permalink
Browse files

Update ruby versions (#3426)

* Now require at least ruby 2.4.5

* Update travis rvm version to support ruby 2.6.1

* Use bundler 2.0 in travis config

https://docs.travis-ci.com/user/languages/ruby/#bundler-20
  • Loading branch information...
bricesanchez authored and parndt committed Feb 12, 2019
1 parent 2eb4f07 commit 710eaf5d766a4e22303d5634ae34107857419ed5
Showing with 7 additions and 6 deletions.
  1. +6 −5 .travis.yml
  2. +1 −1 core/lib/refinery/version.rb
@@ -6,7 +6,9 @@ addons:
packages:
- chromium-chromedriver
cache: bundler
before_install: gem install bundler
before_install:
- gem update --system
- gem install bundler
bundler_args: --without development
before_script:
- export RETRY_COUNT=3
@@ -30,7 +32,6 @@ notifications:
webhooks:
- https://webhooks.gitter.im/e/b5d48907cdc89864b874
rvm:
- 2.5.0
- 2.4.3
- 2.3.6
- 2.2.9
- 2.6.1
- 2.5.3
- 2.4.5
@@ -13,7 +13,7 @@ def to_s
end

def required_ruby_version
'>= 2.2.2'
'>= 2.4.5'
end
end
end

0 comments on commit 710eaf5

Please sign in to comment.
You can’t perform that action at this time.