If i edit a Page, all the HTML content is deleted!! BIG ISSU #1891

Closed
oshovah opened this Issue Aug 21, 2012 · 11 comments

6 participants

@oshovah

Hi

If i insert a table in my Content, then save the page and edit it once again. The Table is gone... the content of the cells are still there, but not the table. Also if i insert, as example, google Maps. After saving and editing again, the Code is gone... Only a few strange tags are still there.

PLS help, this issu makes impossible to add a simple table to the content...

System:
Rails 3.2.6
ruby 1.9.3p194
refinerycms (2.0.8)

@kandadaboggu

I am encountering the same issue with 2.0.8.
The table and input tags are persisted in the database during the first save.
During subsequent loading the editor strips them out. Any further save results in a page without table/input tags.

@oshovah I reverted back to 2.0.6 to get around the issue.

@parndt
Refinery member
@kandadaboggu

I am using jQuery "1.7.2"

@oshovah

In my application.js is the jQuery Library v1.7.2 included.

@amasses

I can verify this happens with Refinery 2.0.8 when using section tags with class, id or data- attributes.

I have reverted to 2.0.6 in the mean time.

@parndt
Refinery member
@kandadaboggu

Everything works in 2.0.6.

@amasses
@Matho

@parndt see resolve@dea0e35 Without sanitize it work on refinery v2.0.8

@ugisozols
Refinery member

Ah it makes sense now. I guess we can revert that because users (admins) can't do any real harm by trying to inject some js (I mean they can harm only themselves ...)

@ugisozols
Refinery member

Reverted here - resolve@9e8b0da

@parndt parndt closed this Aug 29, 2012
@ugisozols ugisozols added a commit that referenced this issue Sep 25, 2012
@ugisozols ugisozols Add regression spec for #1891. 03e9e2f
@ugisozols ugisozols added a commit that referenced this issue Sep 25, 2012
@ugisozols ugisozols Add regression spec for #1891. 3d1f478
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment