"rails generate refinery:engine ipsum" throw nasty exception #1897

Closed
keram opened this Issue Aug 24, 2012 · 1 comment

2 participants

@keram

rails generate refinery:engine lorem

/home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/refinerycms-core-2.0.8/lib/refinery/extension_generation.rb:307:in `sanity_check!': undefined local variable or method `generator_command' for #<Refinery::EngineGenerator:0x9d4287c> (NameError)
 from /home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/refinerycms-core-2.0.8/lib/generators/refinery/engine/engine_generator.rb:21:in `generate'
from /home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/thor-0.16.0/lib/thor/task.rb:27:in `run'
from /home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/thor-0.16.0/lib/thor/invocation.rb:120:in `invoke_task'
from /home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/thor-0.16.0/lib/thor/invocation.rb:126:in `block in invoke_all'
from /home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/thor-0.16.0/lib/thor/invocation.rb:126:in `each'
from /home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/thor-0.16.0/lib/thor/invocation.rb:126:in `map'
from /home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/thor-0.16.0/lib/thor/invocation.rb:126:in `invoke_all'
from /home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/thor-0.16.0/lib/thor/group.rb:238:in `dispatch'
from /home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/thor-0.16.0/lib/thor/base.rb:425:in `start'
from /home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/railties-3.2.8/lib/rails/generators.rb:171:in `invoke'
from /home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/railties-3.2.8/lib/rails/commands/generate.rb:12:in `<top (required)>'
from /home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
from /home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `block in require'
from /home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:236:in `load_dependency'
from /home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
from /home/user/.rvm/gems/ruby-1.9.3-p194@test/gems/railties-3.2.8/lib/rails/commands.rb:29:in `<top (required)>'
from script/rails:6:in `require'
from script/rails:6:in `<main>'
@parndt
Refinery member

Confirm

@parndt parndt closed this in ac1c68f Aug 26, 2012
@parndt parndt added a commit that referenced this issue Aug 26, 2012
@parndt parndt Fixes #1897 by defining generator_command in all generators.
Conflicts:
	core/lib/refinery/extension_generation.rb
7b30821
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment