'Application is not a class' when trying to update to latest version #589

Closed
amcates opened this Issue Apr 5, 2011 · 4 comments

Comments

Projects
None yet
2 participants
@amcates

amcates commented Apr 5, 2011

I'm trying to upgrade from '0.9.8.9' to '0.9.9.15' and I'm following these instructions, http://tinyurl.com/3tb4yzw

I've tried both 'rails generate refinerycms --update' and 'refinerycms /path/to/project --update'.
The first gives me the error 'Application is not a class' and the later tells me to use the first command.

/Users/amcates/Projects/cent/config/application.rb:10: Application is not a class (TypeError)
    from /Library/Ruby/Gems/1.8/gems/railties-3.0.5/lib/rails/commands.rb:15:in `require'
    from /Library/Ruby/Gems/1.8/gems/railties-3.0.5/lib/rails/commands.rb:15
    from script/rails:6:in `require'
    from script/rails:6
@parndt

This comment has been minimized.

Show comment Hide comment
@parndt

parndt Apr 5, 2011

Owner

You have to first update to 0.9.9 before you can use any more point releases in the series. This functionality was stripped out at resolve/refinerycms@ed623d8 , I'll update the guide.

Owner

parndt commented Apr 5, 2011

You have to first update to 0.9.9 before you can use any more point releases in the series. This functionality was stripped out at resolve/refinerycms@ed623d8 , I'll update the guide.

@parndt

This comment has been minimized.

Show comment Hide comment
@parndt

parndt Apr 5, 2011

Owner

Updated the update tutorial with a clearer warning. Closed by 59fb7b6

Owner

parndt commented Apr 5, 2011

Updated the update tutorial with a clearer warning. Closed by 59fb7b6

@parndt parndt closed this Apr 5, 2011

@amcates

This comment has been minimized.

Show comment Hide comment
@amcates

amcates Apr 5, 2011

Thanks!!! You might also want to update this page, http://www.refinerycms.com/blog/whats-new-in-refinery-cms-099

The step that says:

First install/update your refinerycms gem:

gem install refinerycms

should probably read

gem install refinerycms --version '=0.9.9'

amcates commented Apr 5, 2011

Thanks!!! You might also want to update this page, http://www.refinerycms.com/blog/whats-new-in-refinery-cms-099

The step that says:

First install/update your refinerycms gem:

gem install refinerycms

should probably read

gem install refinerycms --version '=0.9.9'
@parndt

This comment has been minimized.

Show comment Hide comment
@parndt

parndt Apr 5, 2011

Owner

Awesome thanks :-)

Owner

parndt commented Apr 5, 2011

Awesome thanks :-)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment