Error installing: requires will_paginate, which is installed #915

Closed
lucashungaro opened this Issue Aug 30, 2011 · 5 comments

Projects

None yet

3 participants

@lucashungaro

$ gem install refinerycms
Error installing refinerycms:
refinerycms-core requires will_paginate (= 3.0.pre2, runtime)

$ gem list

*** LOCAL GEMS ***

(…)
refinerycms-base (1.0.4)
refinerycms-generators (1.0.3)
refinerycms-settings (1.0.4)
(…)
will_paginate (3.0.pre2)

@parndt
Member
parndt commented Aug 31, 2011

Fixed by releasing 1.0.7

Please gem install refinerycms!

@parndt parndt closed this Aug 31, 2011
@lucashungaro

Hmm, okay. Now I'm getting another error. It seems unrelated, but here it goes:

Preparing your application using the refinerycms generator..
Running: cd "/Users/lucashungaro/projects/gonow/instcoin" && "/Users/lucashungaro/.rbenv/versions/1.9/bin/ruby" -S bundle exec rails generate refinerycms
/Users/lucashungaro/.rbenv/versions/1.9/lib/ruby/gems/1.9.1/gems/bundler-1.1.pre.8/lib/bundler/rubygems_integration.rb:143:in block in replace_gem': rails is not part of the bundle. Add it to Gemfile. (Gem::LoadError) from /Users/lucashungaro/.rbenv/versions/1.9/bin/rails:18:in

'

Failed to generate application.
Message: Could not run the refinerycms generator successfully.
Exiting...

@parndt parndt reopened this Aug 31, 2011
@parndt
Member
parndt commented Aug 31, 2011

@lucashungaro will fix asap. thanks!

@nelsonenzo

Thanks @parndt. I'm also having this exact issue and am available for the next 3 or 4 hours if you need a tester. Just my luck, today was my day for doing CMS solution evaluations for work :(

@parndt parndt closed this in 2613b22 Sep 1, 2011
@lucashungaro

Nice! Thank you :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment