New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Android Beta Testing Information & Feedback #1208

Open
skmp opened this Issue Jul 8, 2018 · 155 comments

Comments

Projects
None yet
@skmp
Member

skmp commented Jul 8, 2018

Android Beta opt in

Beta discussion thread

Beta issue reporting

Setting up guide

Game compatibility tracking

Chat


Want to back this issue? Post a bounty on it! We accept bounties via Bountysource.

@skmp skmp added the Discussion label Jul 8, 2018

@spielvan

This comment has been minimized.

spielvan commented Jul 8, 2018

I entered the program of beta tester, I went to test the version that was sent to me 1493906 and when it goes to load the game reicast simply closes, then tested manually and the last functional in my box android tv was edaec54.

Tested device: Android box Tv MX3-G 32bits, with android 4.4.2, more Mali 450 OpenGL ES 2.0

@MrYoso

This comment has been minimized.

MrYoso commented Jul 9, 2018

Can't run any games, even the bios. Instant crash when I try to run a game or bios. S8+ 8.0.0

@ivanmestre

This comment has been minimized.

ivanmestre commented Jul 9, 2018

Same issue, crashes to home screen when loading games. Deleted the app's data and every time I try to set it up again, it crashes to home screen.

Nexus 6P, Android 8.1

@skmp

This comment has been minimized.

Member

skmp commented Jul 9, 2018

Added link to the chat

@renanlricci

This comment has been minimized.

renanlricci commented Jul 9, 2018

Hi! same issue here. I think the file system is the problem, when I try to change de BIOS and games folder the App crashes. Sorry my bad English! ;)

@skmp

This comment has been minimized.

Member

skmp commented Jul 9, 2018

@skmp

This comment has been minimized.

Member

skmp commented Jul 9, 2018

@diegodylard

This comment has been minimized.

diegodylard commented Jul 9, 2018

Same issue. The bios was located succesfully (it seems) but when i try to locate games folder the app goes back to desktop. Same if i manually try to locate dc boot bin folder. Altough the app seemed to have found my game automatically it instantly goes back to desktop when i try to launch it. Device : xiaomi redmi note 4

@MrYoso

This comment has been minimized.

MrYoso commented Jul 9, 2018

Mine shows "r7 [1493906]".

@skmp skmp referenced this issue Jul 9, 2018

Closed

Android 8.1 #1209

1 of 1 task complete
@skmp

This comment has been minimized.

Member

skmp commented Jul 9, 2018

Updated build pushed. You should get the update soon.

@FaceRAX

This comment has been minimized.

FaceRAX commented Jul 9, 2018

Needs to update the cloud vmu, it doesn't let me upload anything. Some settings options need fixing. Games are working fine as always.

@AbandonedCart

This comment has been minimized.

Contributor

AbandonedCart commented Jul 9, 2018

The beta simply extends support to Android 7.0+ and restores functionality to things that were previously working. A lot still needs to be done to update the Android shell.

Cloud VMU, Settings, etc. that have been broken for all Android versions are still broken.

@blackman91

This comment has been minimized.

blackman91 commented Jul 9, 2018

Is this beta build the same as the latest master dev build?

@Emulatorer

This comment has been minimized.

Emulatorer commented Jul 9, 2018

Working nice 👍
But still having a problem in KOF the evolution the touch screen button is gone after the intro of Dreamcast :(

@skmp

This comment has been minimized.

Member

skmp commented Jul 9, 2018

@blackman91 the beta is the tip of #1210. Once that is ready, the beta will be the tip of master. Beta builds are also Release builds, while dev builds are Debug builds by default

@Emulatorer can you open an issue in the gamedb please? https://github.com/reicast/gamedb/issues

@Emulatorer

This comment has been minimized.

Emulatorer commented Jul 9, 2018

@skmp now I reported the issue to
https://github.com/reicast/gamedb/issues

@gannon345

This comment has been minimized.

gannon345 commented Jul 10, 2018

Android r7 1493906:

Crashing when I try to enter any info for the BIOS location, or when I use locate and select it.

@blackman91

This comment has been minimized.

blackman91 commented Jul 10, 2018

Just tested the beta (r7 02901d6), great job this error warning no longer appears at all:
#1009

Selecting bios and games directory no longer crashes the app too.

It seems to be running games fine, will keep testing, only the game Cyber Troopers Virtual On Oratorio Tangram seems to be running at very very low frame rate even with frameskip off and default settings making it unplayable, has anyone else experienced this?

@spielvan

This comment has been minimized.

spielvan commented Jul 10, 2018

@skmp I just tested the (r7 02901d6) as beta tester, and now it is working perfect, there are still graphics bugs, GPU Mali 450 Open GL 2.0. A hug.

@skmp

This comment has been minimized.

Member

skmp commented Jul 10, 2018

Alright. I’ll try to merge everything to master by end of the week then. Meanwhile, would be great to go over the games and note which ones are working nicely and which ones do not.

edit
In general game compatibility issues should be reported to https://github.com/reicast/gamedb, to avoid overloading the issue tracker for the emulator itself.

@skmp

This comment has been minimized.

Member

skmp commented Jul 10, 2018

(Edited first post to point to the gamedb issue tracker)

@Larrynho

This comment has been minimized.

Larrynho commented Jul 10, 2018

Just entered the test. Project Justice 2, only game I have, loads and works, albeit it seems to be a bit slower tan previous lk/Android-studio build I had installed.

S7 edge Exynos.

@blackman91

This comment has been minimized.

blackman91 commented Jul 11, 2018

Just noticed this beta doesn't have the microphone permission on by default after installing, I tried to enable the mic reicast option to play seaman and the app crashed after selecting the game, giving it permission manually in Android app settings fixed the issue though. Also I just got a freeze on MvC2 on the final boss using this beta and had to restart the app :(

@skmp

This comment has been minimized.

Member

skmp commented Jul 11, 2018

@blackman91 can you open an issue for the microphone thing? This should be in reicast-emulator, not gamedb, as it is an actionable item for a developer

@Emulatorer

This comment has been minimized.

Emulatorer commented Jul 12, 2018

This game is running smooth with a minor graphical issue :)
screenshot_2018-07-12-07-50-08

@Blaze08

This comment has been minimized.

Blaze08 commented Oct 2, 2018

there are a bug or issue ingame from power stone 2 after i play in "Original" mode and then "Please insert a vmu!" why? i though the vmu normal though after i save the game... Vmu is normal and why played in original or arcade mode still written "please insert a vmu!" maybe i will send you a email in google play with screenshot

@AbandonedCart

This comment has been minimized.

Contributor

AbandonedCart commented Oct 2, 2018

Did you try formatting the VMU? If you boot the bios and try to open it and it won't open, it needs to be formatted

@Blaze08

This comment has been minimized.

Blaze08 commented Oct 2, 2018

Did you try formatting the VMU? If you boot the bios and try to open it and it won't open, it needs to

Did you try formatting the VMU? If you boot the bios and try to open it and it won't open, it needs to be formatted

still same sir even formatted data and delete data from bios,

@Blaze08

This comment has been minimized.

Blaze08 commented Oct 2, 2018

in reicast around build 2015 there are no sign like that, normal gameplay

@MrPsyMan

This comment has been minimized.

Contributor

MrPsyMan commented Oct 2, 2018

Does the game have a menu to select 50 and 60 hz when it starts for you?

@Blaze08

This comment has been minimized.

Blaze08 commented Oct 2, 2018

Does the game have a menu to select 50 and 60 hz for you?

No Sir there are no selecting 50 or 60 hz from the game,

@MrPsyMan

This comment has been minimized.

Contributor

MrPsyMan commented Oct 2, 2018

I see.

Are you using a beta version from the master or from another branch?

@Blaze08

This comment has been minimized.

Blaze08 commented Oct 2, 2018

I see.

Are you using a beta version from the master or from anotger branch?

using from the master from google play beta version

@MrPsyMan

This comment has been minimized.

Contributor

MrPsyMan commented Oct 2, 2018

Could be a maple dma issue.

You can try to start the game without a vmu (do we support that?), and then insert the vmu when the "insert vmu" message appears.
Do not expect much though.

@Blaze08

This comment has been minimized.

Blaze08 commented Oct 2, 2018

Could be a maple dma issue.

You can try to start the game without a vmu, and then insert the vmu when the "insert vmu" message appears.
Do not expect much though.

okay sir i try

@Blaze08

This comment has been minimized.

Blaze08 commented Oct 2, 2018

PG config doesn't allow me to controls, a bug? yeah sir doesn't support.... it just leaving it blank i can't choose config game in here PGC game doesn't want to open

@Blaze08

This comment has been minimized.

Blaze08 commented Oct 2, 2018

vmu is automatic with 1 mic integrated with it, i can't edit and choosing this options

@MrPsyMan

This comment has been minimized.

Contributor

MrPsyMan commented Oct 2, 2018

Bummer.

@flyinghead @AbandonedCart any clue?

@AbandonedCart

This comment has been minimized.

Contributor

AbandonedCart commented Oct 2, 2018

@Blaze08 By 50 / 60 hz, it is referring to PAL / NTSC. Those should be things you will find in the settings and game config.

@Blaze08

This comment has been minimized.

Blaze08 commented Oct 2, 2018

20181003034033

here screenshot there are no selecting pal/ntsc 50/60 hz only Vmu items in here

@Blaze08

This comment has been minimized.

Blaze08 commented Oct 2, 2018

img_20181003_020743

look at marked red here "please insert a vmu"
and i can't change ingame setting because doesn't support ???

@Blaze08

This comment has been minimized.

Blaze08 commented Oct 2, 2018

x
20181003040233
20181003040218
20181003040241
20181003040251

here it is House of the dead 2 using android kitkat 4.4.0 Gpu mali 450-mp2 model Himax Polymer there are several glitching and flickering sometime lag and drop fps

@AbandonedCart

This comment has been minimized.

Contributor

AbandonedCart commented Oct 2, 2018

@Blaze08 You should probably be posting these to https://github.com/reicast/gamedb/issues since they are getting a bit large for the general beta thread.

@Blaze08

This comment has been minimized.

Blaze08 commented Oct 2, 2018

okay sir i will posting in there too

@blackman91

This comment has been minimized.

blackman91 commented Oct 5, 2018

So what happened with the master builds?
http://builds.reicast.com/

@MezaCorleehone

This comment has been minimized.

MezaCorleehone commented Oct 16, 2018

very good emulator.

just that from the Android 8.1.0
pure android.
I can not start the games.

already has very good features, unfortunately I can not run it.

I hope I can emulate soon

Samsung note 3

  • Snapdragon 2.5 ghz
  • GPU Adreno 330 @ 600 mhz
  • 32 bit system
  • 3 gb of ram
  • Android 8.1.0 custom rom
@kikeminchas

This comment has been minimized.

kikeminchas commented Oct 18, 2018

Hi there

Nvidia Shield TV , Oreo 8.0. (Beta build from 5th October)

  • When quitting emulation of a game, sometimes emulator returns to main menu but game list has disappeared. I can navigate to settings but that screen is also blank. The only solution is to quit emulator and wait a bit (or entering another app and then come back to emulator) or force close the emulator. Games are on Network Share, I believe this has been reported already.

  • Once in game, there is something wrong with the brightness/contrast/gamma of the screen. This one is difficult to explain, loading Crazy Taxy, for instance, the initial SEGA logo is displayed correctly, the white background and the blue SEGA logo are bright, contrast in between them is correct. Inmediately afterwards, I think the ADX logo, presents a greyish, darker white. In game, the colors are dull, contrast and brigthness are low. In dead or Alive 2, the difference is much clearer because the game will switch in between correct brightness and contrast (just before starting a fight) and low brightness/contrast (during the fight)

  • the new 640x480 resolution set does not seem to have any effect on the Shield TV

  • Setting output cable to 'TV' makes game not loading and return to game selection screen (not sure if this is expected, I have to recognize I don't understand so good what are this options doing, I don't see any difference in between none of them in game, I tried them to check if they would solve the low brightness/contrast issue...)

All these tests are performed with Synchronous Rendering (much smoother gameplay). Thanks!

@blackman91

This comment has been minimized.

blackman91 commented Oct 18, 2018

Yes I can confirm the colors issue on latest beta too, just check this:
Reicast standalone latest beta:
screenshot_20181018-124159

Fh branch:
screenshot_20181018-124324

@spielvan

This comment has been minimized.

spielvan commented Oct 18, 2018

Yes I can confirm the colors issue on latest beta too, just check this:
Reicast standalone latest beta:
screenshot_20181018-124159

Fh branch:
screenshot_20181018-124324

What version are you using? I'm using the latest build beta tester, from google play, and DOA2 gets dark on the characters during the fights.

@RaduNastase

This comment has been minimized.

RaduNastase commented Oct 19, 2018

How about the 640x480 setting guys? Is it non-working on all android devices atm?

@kikeminchas

This comment has been minimized.

kikeminchas commented Oct 19, 2018

Just for clarity purposes, the issue with low brightness/contrast is present also in master branch (r8.1). Interesting to know that flyinghead's branch does not have the issue. I can also confirm retroarch's libretro core does not have the issue either (but this one is much slower for me for some reason since some time ago)

EDIT: Fh build has the same brightness/contrast issue for me. This is on a Nvidia Shield TV.
Added issue: #1451

@blackman91

This comment has been minimized.

blackman91 commented Oct 28, 2018

Latest Playstore beta is broken:
#1446

@kikeminchas

This comment has been minimized.

kikeminchas commented Oct 29, 2018

Beta cannot be installed on Nvidia Shield TV. It never appeared in the Android TV version of Google Play but it could be installed from the Desktop. Now the Shield appears grayed out and marked as not compatible.

@Emulatorer

This comment has been minimized.

Emulatorer commented Nov 4, 2018

Why there's no beta update ?
See #1455

@Sokron

This comment has been minimized.

Sokron commented Nov 4, 2018

I´m having the issue that crash instantly when i try to load a game or the bios

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment