Browse files

Use impl instead of flags to determine TH version.

  • Loading branch information...
1 parent 442f9e5 commit 9a3514153d5c1f49b42d4bf1cb391b5e6b4b4b3c @bmillwood bmillwood committed Mar 27, 2012
Showing with 1 addition and 5 deletions.
  1. +1 −5 haskell-src-meta.cabal
View
6 haskell-src-meta.cabal
@@ -17,18 +17,14 @@ description: The translation from haskell-src-exts abstract syntax
extra-source-files: examples/*.hs README
-flag new-th
- Description: Build with template-haskell >= 2.7.0
- Default: False
-
library
build-depends: base >= 4.2 && < 4.6,
haskell-src-exts >= 1.8 && < 1.13,
pretty >= 1.0 && < 1.2,
syb >= 0.1 && < 0.4,
th-lift == 0.5.*
- if flag(new-th)
+ if impl(ghc >= 7.4)
Build-depends: template-haskell >= 2.7 && < 2.9
else
Build-depends: template-haskell >= 2.4 && < 2.7,

0 comments on commit 9a35141

Please sign in to comment.