Permalink
Browse files

Adding messages around Ruby 1.9

  • Loading branch information...
1 parent 5d8973a commit 087092cc62a5ac41da2f5cc1613b3b6157387d6f @abedra abedra committed Jan 19, 2012
Showing with 11 additions and 3 deletions.
  1. +6 −3 bin/rcov
  2. +5 −0 ext/rcovrt/extconf.rb
View
@@ -10,6 +10,12 @@
#
# See LEGAL and LICENSE for additional licensing information.
#
+if RUBY_VERSION =~ /1.9/
+ puts "** Ruby 1.9 is not supported. Please switch to simplecov **"
+ exit 1
+end
+
+
require 'cgi'
require 'rbconfig'
require 'optparse'
@@ -503,9 +509,6 @@ $rcov_code_coverage_analyzer.install_hook
#{{{ Load scripts
begin
- if RUBY_VERSION =~ /1.9/
- puts "** WARNING: Ruby 1.9 Support is experimental at best. Don't expect correct results! **"
- end
pending_scripts = ARGV.clone
ARGV.replace extra_args
until pending_scripts.empty?
View
@@ -1,3 +1,8 @@
+if RUBY_VERSION =~ /1.9/
+ puts "**** Ruby 1.9 is not supported. Please switch to simplecov ****"
+ Kernel.exit 1
+end
+
require 'mkmf'
dir_config("gcov")

1 comment on commit 087092c

FYI, the abort method is a better implementation for this. It writes its argument to STDERR and exits with a status of 1.

Please sign in to comment.