Permalink
Browse files

php 5.3 now provides bundled pcre 8.12 on EL-6

  • Loading branch information...
remicollet committed Sep 4, 2012
1 parent 2e84c30 commit fde3362b3769368eb34a08d0aa95b0fc01e788d3
@@ -5,7 +5,7 @@
Summary: APC caches and optimizes PHP intermediate code
Name: php-pecl-apc
Version: 3.1.13
-Release: 1%{?dist}
+Release: 2%{?dist}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/APC
@@ -19,7 +19,7 @@ Source: http://pecl.php.net/get/APC-%{version}.tgz
Patch0: apc-svn.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
-BuildRequires: php-devel >= 5.1.0, httpd-devel, php-pear, pcre-devel
+BuildRequires: php-devel >= 5.1.0, httpd-devel, php-pear
# For tests
BuildRequires: php-dom
@@ -259,6 +259,10 @@ rm -rf %{buildroot}
%changelog
+* Tue Sep 4 2012 Remi Collet <remi@fedoraproject.org> - 3.1.13-2
+- sync with rawhide
+- EL rebuild
+
* Mon Sep 3 2012 Remi Collet <remi@fedoraproject.org> - 3.1.13-1
- Version 3.1.13 (beta) - API 3.1.0 (stable)
- add patches from upstream (fixes some tests)
@@ -1,4 +1,4 @@
SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
-include ../common/Makefile
+include ../../../common/Makefile
@@ -5,7 +5,7 @@
Name: php-pecl-oauth
Version: 1.2.2
-Release: 3%{?dist}
+Release: 4%{?dist}
Summary: PHP OAuth consumer extension
Group: Development/Languages
License: BSD
@@ -17,7 +17,6 @@ BuildRequires: php-devel
BuildRequires: php-pear
# curl instead of libcurl for old release
BuildRequires: curl-devel
-BuildRequires: pcre-devel
Requires: php(zend-abi) = %{php_zend_api}
Requires: php(api) = %{php_core_api}
@@ -112,6 +111,9 @@ fi
%changelog
+* Tue Sep 4 2012 Remi Collet <remi@fedoraproject.org> - 1.2.2-4
+- EL rebuild
+
* Sun Nov 13 2011 Remi Collet <remi@fedoraproject.org> - 1.2.2-3
- build against php 5.4
View
@@ -46,7 +46,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{phpname}
Version: 5.3.16
-Release: 2%{?dist}
+Release: 3%{?dist}
License: PHP
Group: Development/Languages
URL: http://www.php.net/
@@ -123,8 +123,8 @@ BuildRequires: sqlite-devel >= 3.5.9
BuildRequires: sqlite-devel >= 3.0.0
%endif
BuildRequires: zlib-devel, smtpdaemon, libedit-devel
-%if 0%{?fedora} >= 10 || 0%{?rhel} >= 6
-BuildRequires: pcre-devel >= 7.8
+%if 0%{?fedora} >= 14 || 0%{?rhel} >= 7
+BuildRequires: pcre-devel >= 8.10
%endif
BuildRequires: bzip2, perl, libtool >= 1.4.3, gcc-c++
%if 0%{?rhel}%{?fedora} > 4
@@ -268,6 +268,9 @@ package and the %{phpname}-cli package.
Group: Development/Libraries
Summary: Files needed for building PHP extensions
Requires: %{phpname}%{?_isa} = %{version}-%{release}, autoconf, automake
+%if 0%{?fedora} >= 14 || 0%{?rhel} >= 7
+Requires: pcre-devel%{?_isa}
+%endif
Obsoletes: %{phpname}-pecl-pdo-devel
Provides: php-zts-devel = %{version}-%{release}
Provides: php-zts-devel%{?_isa} = %{version}-%{release}
@@ -866,7 +869,7 @@ ln -sf ../configure
--with-iconv \
--with-jpeg-dir=%{_prefix} \
--with-openssl \
-%if 0%{?fedora} >= 10 || 0%{?rhel} >= 6
+%if 0%{?fedora} >= 14 || 0%{?rhel} >= 7
--with-pcre-regex=%{_prefix} \
%endif
--with-zlib \
@@ -1493,6 +1496,9 @@ fi
%endif
%changelog
+* Tue Sep 4 2012 Remi Collet <remi@fedoraproject.org> 5.3.16-3
+- use system pcre only on fedora >= 14 (version 8.10)
+
* Mon Sep 3 2012 Remi Collet <remi@fedoraproject.org> 5.3.16-2
- obsoletes php53 packages to allow smoth update
- clean unneeded conditionnal
View
@@ -122,7 +122,7 @@ BuildRequires: sqlite-devel >= 3.0.0
%endif
BuildRequires: zlib-devel, smtpdaemon, libedit-devel
%if 0%{?fedora} >= 14 || 0%{?rhel} >= 7
-BuildRequires: pcre-devel >= 8.0
+BuildRequires: pcre-devel >= 8.10
%endif
BuildRequires: bzip2, perl, libtool >= 1.4.3, gcc-c++
BuildRequires: libtool-ltdl-devel
@@ -270,6 +270,9 @@ package and the php-cli package.
Group: Development/Libraries
Summary: Files needed for building PHP extensions
Requires: php%{?_isa} = %{version}-%{release}, autoconf, automake
+%if 0%{?fedora} >= 14 || 0%{?rhel} >= 7
+Requires: pcre-devel%{?_isa}
+%endif
Obsoletes: php-pecl-pdo-devel
Provides: php-zts-devel = %{version}-%{release}
Provides: php-zts-devel%{?_isa} = %{version}-%{release}

0 comments on commit fde3362

Please sign in to comment.