Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

LibRaw soname bump #123

Open
remicollet opened this issue Aug 8, 2019 · 5 comments

Comments

@remicollet
Copy link
Owner

commented Aug 8, 2019

In RHEL 7.7, LibRaw was updated to 0.19.2, with a new soname (5 => 19)

This breaks dependency of ImageMagick 6 and 7 in the repository

See https://forum.remirepo.net/viewtopic.php?id=3873

@remicollet

This comment has been minimized.

Copy link
Owner Author

commented Aug 8, 2019

Workaround:

  • ImageMagick6-6.9.10.59-2 and ImageMagick7-7.0.8.59-2 rebuild against LibRaw 0.19.2-1 from RHEL-7.7
  • LibRaw-0.19.2-0 available for CentOS 7.6 users

TODO: remove LibRaw from the repository when CentOS 7.7 will be released

@remicollet

This comment has been minimized.

Copy link
Owner Author

commented Aug 13, 2019

Also https://forum.remirepo.net/viewtopic.php?id=3875

=> Package: libkdcraw-4.10.5-5.el7.x86_64 (@base)

@remicollet

This comment has been minimized.

Copy link
Owner Author

commented Aug 13, 2019

@schroedr

This comment has been minimized.

Copy link

commented Aug 16, 2019

I've encountered the same broken dependency issue with shotwell.
Starting point is CentOS 7.5, Remi php 7.2, shotwell 0.24
Wanted to update to CentOS 7.6 shotwell 0.28.
The conflict was libraw.so.5 vs libraw.so.19.
Ultimately I uninstalled shotwell and got the yum update to work (without needing --exclude or --skip-broken)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.