Skip to content
Browse files

Sort out the Gemfile: require capybara, rspec, newer activerecord; up…

…date env.rb for RSpec 2.
  • Loading branch information...
1 parent cdc37da commit 6383d2168e6d0770d13cd29fa86852ecfc988212 @markoa markoa committed
Showing with 57 additions and 17 deletions.
  1. +2 −0 .gitignore
  2. +3 −1 Gemfile
  3. +50 −13 Gemfile.lock
  4. +2 −3 features/support/env.rb
View
2 .gitignore
@@ -1,3 +1,5 @@
*.swp
config.yml
database.yml
+.bundle
+vendor/bundle/
View
4 Gemfile
@@ -2,11 +2,13 @@ source 'http://rubygems.org'
gem 'sinatra'
gem 'rack'
-gem 'activerecord', '3.0.0'
+gem 'activerecord', '3.0.3'
gem 'fastercsv'
group :test do
gem 'database_cleaner'
+ gem 'capybara'
+ gem 'rspec'
gem 'cucumber-sinatra'
gem 'cucumber'
end
View
63 Gemfile.lock
@@ -1,19 +1,30 @@
GEM
remote: http://rubygems.org/
specs:
- activemodel (3.0.0)
- activesupport (= 3.0.0)
+ activemodel (3.0.3)
+ activesupport (= 3.0.3)
builder (~> 2.1.2)
- i18n (~> 0.4.1)
- activerecord (3.0.0)
- activemodel (= 3.0.0)
- activesupport (= 3.0.0)
- arel (~> 1.0.0)
+ i18n (~> 0.4)
+ activerecord (3.0.3)
+ activemodel (= 3.0.3)
+ activesupport (= 3.0.3)
+ arel (~> 2.0.2)
tzinfo (~> 0.3.23)
- activesupport (3.0.0)
- arel (1.0.1)
- activesupport (~> 3.0.0)
+ activesupport (3.0.3)
+ arel (2.0.7)
builder (2.1.2)
+ capybara (0.4.1.1)
+ celerity (>= 0.7.9)
+ culerity (>= 0.2.4)
+ mime-types (>= 1.16)
+ nokogiri (>= 1.3.3)
+ rack (>= 1.0.0)
+ rack-test (>= 0.5.4)
+ selenium-webdriver (>= 0.0.27)
+ xpath (~> 0.1.3)
+ celerity (0.8.7)
+ childprocess (0.1.6)
+ ffi (~> 0.6.3)
cucumber (0.8.5)
builder (~> 2.1.2)
diff-lcs (~> 1.1.2)
@@ -22,16 +33,38 @@ GEM
term-ansicolor (~> 1.0.4)
cucumber-sinatra (0.3.0)
templater (>= 1.0.0)
+ culerity (0.2.15)
database_cleaner (0.5.2)
diff-lcs (1.1.2)
extlib (0.9.15)
fastercsv (1.5.3)
+ ffi (0.6.3)
+ rake (>= 0.8.7)
gherkin (2.1.5)
trollop (~> 1.16.2)
highline (1.5.0)
- i18n (0.4.1)
+ i18n (0.5.0)
json_pure (1.4.6)
+ mime-types (1.16)
+ nokogiri (1.4.4)
rack (1.2.1)
+ rack-test (0.5.7)
+ rack (>= 1.0)
+ rake (0.8.7)
+ rspec (2.4.0)
+ rspec-core (~> 2.4.0)
+ rspec-expectations (~> 2.4.0)
+ rspec-mocks (~> 2.4.0)
+ rspec-core (2.4.0)
+ rspec-expectations (2.4.0)
+ diff-lcs (~> 1.1.2)
+ rspec-mocks (2.4.0)
+ rubyzip (0.9.4)
+ selenium-webdriver (0.1.2)
+ childprocess (~> 0.1.5)
+ ffi (~> 0.6.3)
+ json_pure
+ rubyzip
sinatra (1.0)
rack (>= 1.0)
templater (1.0.0)
@@ -40,16 +73,20 @@ GEM
highline (>= 1.4.0)
term-ansicolor (1.0.5)
trollop (1.16.2)
- tzinfo (0.3.23)
+ tzinfo (0.3.24)
+ xpath (0.1.3)
+ nokogiri (~> 1.3)
PLATFORMS
ruby
DEPENDENCIES
- activerecord (= 3.0.0)
+ activerecord (= 3.0.3)
+ capybara
cucumber
cucumber-sinatra
database_cleaner
fastercsv
rack
+ rspec
sinatra
View
5 features/support/env.rb
@@ -6,14 +6,13 @@
require 'capybara'
require 'capybara/cucumber'
-require 'spec'
Capybara.app = ComingSoon
class ComingSoonWorld
include Capybara
- include Spec::Expectations
- include Spec::Matchers
+ include RSpec::Expectations
+ include RSpec::Matchers
end
World do

0 comments on commit 6383d21

Please sign in to comment.
Something went wrong with that request. Please try again.