Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

<a id="ContextButton">≡</a><br /> will write <a id="ContextButton">??/a><br /> #1

Closed
lee-yunseok opened this issue Jul 2, 2019 · 13 comments

Comments

Projects
None yet
2 participants
@lee-yunseok
Copy link

commented Jul 2, 2019

renpy-shell.html,

<a id="ContextButton">≡</a><br /> button line will write <a id="ContextButton">??/a><br />.

@lee-yunseok lee-yunseok changed the title ??/a> in Chrome. <a id="ContextButton">≡</a><br /> will write <a id="ContextButton">??/a><br /> Jul 2, 2019

@Beuc

This comment has been minimized.

Copy link
Collaborator

commented Jul 2, 2019

Thanks for the report!
I guess this symbol is not available in your default font.
I'm thinking of replacing it with an inline image.

@lee-yunseok

This comment has been minimized.

Copy link
Author

commented Jul 2, 2019

No problem with you? Is it affected by system fonts? When building a web app, the symbol will broken code.

@Beuc

This comment has been minimized.

Copy link
Collaborator

commented Jul 2, 2019

No problem here.
Can you post a screenshot so I better understand what's happening?

@lee-yunseok

This comment has been minimized.

Copy link
Author

commented Jul 2, 2019

When I built with renpyweb using renpy launcher, the symbol will bronken in the index.html like below.

notepad++_2019-07-03_00-43-22

So I have to modify the code in index.html manually as a symbol.

@Beuc

This comment has been minimized.

Copy link
Collaborator

commented Jul 2, 2019

Make sure you are editing it as a UTF-8 file (as set in the html meta-data).
By screenshot, I meant a screenshot of the browser window :)

@Beuc

This comment has been minimized.

Copy link
Collaborator

commented Jul 2, 2019

Also can you try with &#8801; instead of the symbol? This would solve charset issues.

@lee-yunseok

This comment has been minimized.

Copy link
Author

commented Jul 2, 2019

I mean, if I build project in renpy using renpyweb, the code of index.html will bronken like my attached above. So I have to change ?? to ≡<.

@Beuc

This comment has been minimized.

Copy link
Collaborator

commented Jul 2, 2019

OK, so:

  • I can't reproduce your problem, it works fine for me with the latest Ren'Py 7.3.2 (and all other versions)
  • I suspect the HTML is fine, but you read it with the wrong charset

What we can do: please give me:

  • the exact Ren'Py version you're using
  • your unmodified index.html with the error so I can download it
  • a screenshot of your browser when there's the error
@lee-yunseok

This comment has been minimized.

Copy link
Author

commented Jul 2, 2019

chrome_2019-07-03_04-42-30

@Beuc

This comment has been minimized.

Copy link
Collaborator

commented Jul 2, 2019

Thanks a lot!
Does it work better with this? (place it in renpy-7.3.2/launcher/game/web.rpy)
web.zip

@lee-yunseok

This comment has been minimized.

Copy link
Author

commented Jul 2, 2019

Yes, the error is resolved.

@Beuc

This comment has been minimized.

Copy link
Collaborator

commented Jul 2, 2019

Thanks for testing!
I added the web.rpy fix in Ren'Py itself, and also used &#8801; just in case.

@lee-yunseok

This comment has been minimized.

Copy link
Author

commented Jul 2, 2019

Thank you for your work, Beuc.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.