Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Fixes confusing installer UI that says it will install for all users …

…and then only installs for the current user. Apparently that involves using PackageMaker and deselecting all possible install destinations. *glares at PackageMaker*

Signed-off-by: Jonathan 'Wolf' Rentzsch <jwr.git@redshed.net>
  • Loading branch information...
commit 2d74d2b477a76a07dd4bf9d9ac45a69d18d22eee 1 parent 80c7687
Simone Manganelli authored committed
View
2  Package/Package Template.pmdoc/01clicktoflash.xml
@@ -1 +1 @@
-<pkgref spec="1.12" uuid="3EB531D4-9A8B-4253-BCC3-2C37FD799BE1"><config><identifier>com.github.rentzsch.clicktoflash.pkg</identifier><version>1</version><description></description><post-install type="none"/><installFrom relative="true" mod="true" includeRoot="true">../build/Release/ClickToFlash.plugin</installFrom><installTo mod="true">/tmp</installTo><flags><followSymbolicLinks/><overwriteDirectoryPermissions/><allowRevert/><mod>overwriteDirectoryPermissions</mod><mod>allowRevert</mod></flags><packageStore type="internal"></packageStore><mod>installFrom.path</mod><mod>scripts.scriptsDirectoryPath.isRelativeType</mod><mod>installTo.isAbsoluteType</mod><mod>installTo.isRelativeType</mod><mod>installFrom.isAbsoluteType</mod><mod>extraFiles</mod><mod>version</mod><mod>includeRoot</mod><mod>identifier</mod><mod>parent</mod><mod>scripts.postinstall.path</mod><mod>requireAuthorization</mod><mod>postInstall</mod><mod>scripts.preinstall.path</mod><mod>relocatable</mod><mod>installFrom.isRelativeType</mod><mod>scripts.scriptsDirectoryPath.path</mod><mod>installTo.path</mod><mod>scripts.preinstall.isRelativeType</mod><mod>installTo</mod></config><scripts><preinstall relative="true" mod="true">preflight.txt</preinstall><postinstall relative="true" mod="true">postflight.txt</postinstall></scripts><contents><file-list>01clicktoflash-contents.xml</file-list><component id="com.github.rentzsch.clicktoflash" path="/Users/simmy/clicktoflash+simX/build/Release/ClickToFlash.plugin" version="1.4fc5"><component id="org.andymatuschak.Sparkle" path="/Users/simmy/clicktoflash+simX/build/Release/ClickToFlash.plugin/Contents/Frameworks/Sparkle.framework" version="1.5"/></component><filter>/CVS$</filter><filter>/\.svn$</filter><filter>/\.cvsignore$</filter><filter>/\.cvspass$</filter><filter>/\.DS_Store$</filter></contents><extra-files/></pkgref>
+<pkgref spec="1.12" uuid="3EB531D4-9A8B-4253-BCC3-2C37FD799BE1"><config><identifier>com.github.rentzsch.clicktoflash.pkg</identifier><version>1</version><description></description><post-install type="none"/><installFrom relative="true" mod="true" includeRoot="true">../build/Release/ClickToFlash.plugin</installFrom><installTo mod="true">/tmp</installTo><flags><followSymbolicLinks/><overwriteDirectoryPermissions/><allowRevert/><mod>overwriteDirectoryPermissions</mod><mod>allowRevert</mod></flags><packageStore type="internal"></packageStore><mod>installTo</mod><mod>scripts.scriptsDirectoryPath.isRelativeType</mod><mod>installTo.isAbsoluteType</mod><mod>installTo.isRelativeType</mod><mod>installFrom.isAbsoluteType</mod><mod>extraFiles</mod><mod>version</mod><mod>includeRoot</mod><mod>identifier</mod><mod>parent</mod><mod>scripts.postinstall.path</mod><mod>requireAuthorization</mod><mod>postInstall</mod><mod>scripts.preinstall.path</mod><mod>relocatable</mod><mod>installFrom.isRelativeType</mod><mod>scripts.scriptsDirectoryPath.path</mod><mod>installFrom.path</mod><mod>installTo.path</mod><mod>scripts.preinstall.isRelativeType</mod></config><scripts><preinstall relative="true" mod="true">preflight.txt</preinstall><postinstall relative="true" mod="true">postflight.txt</postinstall></scripts><contents><file-list>01clicktoflash-contents.xml</file-list><component id="com.github.rentzsch.clicktoflash" path="/Users/simmy/clicktoflash+simX/build/Release/ClickToFlash.plugin" version="1.4fc5"><component id="org.andymatuschak.Sparkle" path="/Users/simmy/clicktoflash+simX/build/Release/ClickToFlash.plugin/Contents/Frameworks/Sparkle.framework" version="1.5"/></component><filter>/CVS$</filter><filter>/\.svn$</filter><filter>/\.cvsignore$</filter><filter>/\.cvspass$</filter><filter>/\.DS_Store$</filter></contents><extra-files/></pkgref>
View
4 Package/Package Template.pmdoc/index.xml
@@ -1,5 +1,5 @@
-<pkmkdoc spec="1.12"><properties><title>ClickToFlash</title><build>/Users/simmy/clicktoflash+simX/Package/Package Template.pkg</build><organization>com.github.rentzsch.clicktoflash</organization><userSees ui="easy"/><min-target os="3"/><domain system="true"/></properties><distribution><versions min-spec="1.000000"/><scripts></scripts></distribution><description>ClickToFlash PackageMaker template.
+<pkmkdoc spec="1.12"><properties><title>ClickToFlash</title><build>/Users/simmy/clicktoflash+simX/Package/Package Template.pkg</build><organization>com.github.rentzsch.clicktoflash</organization><userSees ui="easy"/><min-target os="3"/><domain/></properties><distribution><versions min-spec="1.000000"/><scripts></scripts></distribution><description>ClickToFlash PackageMaker template.
Make sure that you have the latest version of XCode when making changes as PackageMaker is generally a bit buggy. Use at least version 3.0.3.
-This package is currently configured to always install in $HOME. I didn't find a good way to let the user choose a system wide installation yet as we would always have to require admin rights.</description><contents><choice title="Internet Plug-Ins" id="clicktoflash" starts_selected="true" starts_enabled="true" starts_hidden="false"><pkgref id="com.github.rentzsch.clicktoflash.pkg"/></choice></contents><resources bg-scale="none" bg-align="bottomright"><locale lang="en"><resource relative="true" mod="true" type="background">Background.png</resource><resource relative="true" mod="true" type="readme">Read Me Panel.rtf</resource><resource relative="true" mod="true" type="conclusion">Conclusion Panel.rtfd</resource></locale></resources><requirements><requirement id="bund" operator="ge" value="'3.0.0'" required="false"><file>/Applications/Safari.app</file><key>CFBundleShortVersionString</key><message-title>ClickToFlash requires Safari 3.0 or greater</message-title><message>You will not be able to use ClickToFlash with the version of Safari installed on your system. Use Software Update to upgrade to the latest version.</message></requirement><requirement id="sosv" operator="ge" value="'10.5.0'"><message-title>ClickToFlash requires MacOS X 10.5 Leopard</message-title><message>ClickToFlash cannot be used with the version of MacOS X installed on your computer.</message></requirement></requirements><flags/><extra-files/><item type="file">01clicktoflash.xml</item><mod>properties.userDomain</mod><mod>preinstallActions.actions</mod><mod>properties.systemDomain</mod><mod>properties.customizeOption</mod><mod>properties.anywhereDomain</mod><mod>extraFiles</mod><mod>properties.title</mod><mod>description</mod><mod>postinstallActions.actions</mod></pkmkdoc>
+This package is currently configured to always install in $HOME. I didn't find a good way to let the user choose a system wide installation yet as we would always have to require admin rights.</description><contents><choice title="Internet Plug-Ins" id="clicktoflash" starts_selected="true" starts_enabled="true" starts_hidden="false"><pkgref id="com.github.rentzsch.clicktoflash.pkg"/></choice></contents><resources bg-scale="none" bg-align="bottomright"><locale lang="en"><resource relative="true" mod="true" type="background">Background.png</resource><resource relative="true" mod="true" type="readme">Read Me Panel.rtf</resource><resource relative="true" mod="true" type="conclusion">Conclusion Panel.rtfd</resource></locale></resources><requirements><requirement id="bund" operator="ge" value="'3.0.0'" required="false"><file>/Applications/Safari.app</file><key>CFBundleShortVersionString</key><message-title>ClickToFlash requires Safari 3.0 or greater</message-title><message>You will not be able to use ClickToFlash with the version of Safari installed on your system. Use Software Update to upgrade to the latest version.</message></requirement><requirement id="sosv" operator="ge" value="'10.5.0'"><message-title>ClickToFlash requires MacOS X 10.5 Leopard</message-title><message>ClickToFlash cannot be used with the version of MacOS X installed on your computer.</message></requirement></requirements><flags/><extra-files/><item type="file">01clicktoflash.xml</item><mod>properties.userDomain</mod><mod>properties.anywhereDomain</mod><mod>properties.systemDomain</mod><mod>properties.customizeOption</mod><mod>preinstallActions.actions</mod><mod>extraFiles</mod><mod>properties.title</mod><mod>description</mod><mod>postinstallActions.actions</mod></pkmkdoc>
Please sign in to comment.
Something went wrong with that request. Please try again.