Permalink
Browse files

remove version check, just assume pyev / libev > 4.0

  • Loading branch information...
1 parent 17fada1 commit 688bcaf6f438aa36ea1df3574bbbd9abe665dd18 @rep committed Nov 8, 2013
Showing with 2 additions and 4 deletions.
  1. +2 −4 evnet/__init__.py
View
@@ -44,8 +44,7 @@ def loop(l=default_loop):
sigint_watcher.start()
try:
- if pyev.version()[1] < '4.00': l.loop()
- else: l.start()
+ l.start()
except OSError, e:
traceback.print_exc()
print 'oserror', e, e.args
@@ -55,8 +54,7 @@ def unloop(l=default_loop):
if cb.alive():
cb()
- if pyev.version()[1] < '4.00': l.unloop()
- else: l.stop()
+ l.stop()
def connectssl(host, port, cert=None):
if cert == None: raise EVException('connectssl requires a certificate.')

0 comments on commit 688bcaf

Please sign in to comment.