New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Project Broken after update android studio and gradle version #467

Closed
steelxtreme opened this Issue Mar 13, 2017 · 19 comments

Comments

Projects
None yet
7 participants
@steelxtreme

steelxtreme commented Mar 13, 2017

hello, I was using requery succesfully after an android tools and gradle update, now can't generate classes:
I've tried everything.

this is my console output after full rebuild:

`
Executing tasks: [clean, :app:generateDebugSources, :app:generateDebugAndroidTestSources, :app:mockableAndroidJar, :app:prepareDebugUnitTestDependencies, :app:compileDebugSources, :app:compileDebugAndroidTestSources, :app:compileDebugUnitTestSources]

Configuration on demand is an incubating feature.
NDK is missing a "platforms" directory.
If you are using NDK, verify the ndk.dir is set to a valid NDK directory. It is currently set to /home/devquilla/Android/Sdk/ndk-bundle.
If you are not using NDK, unset the NDK variable from ANDROID_NDK_HOME or local.properties to remove this warning.

:clean
:app:clean
:app:preBuild UP-TO-DATE
:app:preDebugBuild UP-TO-DATE
:app:checkDebugManifest
:app:preReleaseBuild UP-TO-DATE
:app:prepareComAndroidDatabindingAdapters131Library
:app:prepareComAndroidDatabindingLibrary131Library
:app:prepareComAndroidSupportAnimatedVectorDrawable2520Library
:app:prepareComAndroidSupportAppcompatV72520Library
:app:prepareComAndroidSupportSupportCompat2520Library
:app:prepareComAndroidSupportSupportCoreUi2520Library
:app:prepareComAndroidSupportSupportCoreUtils2520Library
:app:prepareComAndroidSupportSupportFragment2520Library
:app:prepareComAndroidSupportSupportMediaCompat2520Library
:app:prepareComAndroidSupportSupportV42520Library
:app:prepareComAndroidSupportSupportVectorDrawable2520Library
:app:prepareIoReactivexRxandroid121Library
:app:prepareIoRequeryRequeryAndroid120Library
:app:prepareDebugDependencies
:app:compileDebugAidl
:app:compileDebugRenderscript UP-TO-DATE
:app:generateDebugBuildConfig
:app:generateDebugResValues
:app:generateDebugResources
:app:mergeDebugResources
:app:dataBindingProcessLayoutsDebug
:app:processDebugManifest
:app:processDebugResources
:app:generateDebugSources
:app:preDebugAndroidTestBuild UP-TO-DATE
:app:prepareComAndroidSupportTestEspressoEspressoCore222Library
:app:prepareComAndroidSupportTestEspressoEspressoIdlingResource222Library
:app:prepareComAndroidSupportTestExposedInstrumentationApiPublish05Library
:app:prepareComAndroidSupportTestRules05Library
:app:prepareComAndroidSupportTestRunner05Library
:app:prepareDebugAndroidTestDependencies
:app:compileDebugAndroidTestAidl
:app:processDebugAndroidTestManifest
:app:compileDebugAndroidTestRenderscript UP-TO-DATE
:app:generateDebugAndroidTestBuildConfig
:app:generateDebugAndroidTestResValues
:app:generateDebugAndroidTestResources
:app:mergeDebugAndroidTestResources
:app:processDebugAndroidTestResources
:app:generateDebugAndroidTestSources
:app:mockableAndroidJar
:app:preDebugUnitTestBuild UP-TO-DATE
:app:prepareDebugUnitTestDependencies
:app:dataBindingExportBuildInfoDebug
:app:incrementalDebugJavaCompilationSafeguard
:app:javaPreCompileDebug
:app:transformClassesAndDataBindingWithDataBindingMergeArtifactsForDebug
:app:compileDebugJavaWithJavac
/home/devquilla/AndroidStudioProjects/Wayuu/app/build/generated/source/apt/debug/main/zlab/com/wayuu/repository/model/DictionaryEntity.java:235: error: cannot find symbol
notifyPropertyChanged(main.zlab.com.wayuu.repository.model.BR.word);
^
symbol: class BR
location: package main.zlab.com.wayuu.repository.model
/home/devquilla/AndroidStudioProjects/Wayuu/app/build/generated/source/apt/debug/main/zlab/com/wayuu/repository/model/DictionaryEntity.java:246: error: cannot find symbol
notifyPropertyChanged(main.zlab.com.wayuu.repository.model.BR.definition);
^
symbol: class BR
location: package main.zlab.com.wayuu.repository.model
/home/devquilla/AndroidStudioProjects/Wayuu/app/build/generated/source/apt/debug/main/zlab/com/wayuu/repository/model/DictionaryEntity.java:257: error: cannot find symbol
notifyPropertyChanged(main.zlab.com.wayuu.repository.model.BR.letra);
^
symbol: class BR
location: package main.zlab.com.wayuu.repository.model
3 errors

FAILED

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ':app:compileDebugJavaWithJavac'.

Compilation failed; see the compiler error output for details.

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 5.578 secs

`

also after --info i did notice:

`
Executing task ':app:compileDebugJavaWithJavac' (up-to-date check took 0.004 secs) due to:
No history is available.
All input files are considered out-of-date for incremental task ':app:compileDebugJavaWithJavac'.
Compiling with source level 1.7 and target level 1.7.
file or directory '/home/devquilla/AndroidStudioProjects/Wayuu/app/src/debug/java', not found
file or directory '/home/devquilla/AndroidStudioProjects/Wayuu/app/build/generated/source/rs/debug', not found
Compiling with JDK Java compiler API.

`

Any help would be appreciated.

@npurushe

This comment has been minimized.

Show comment
Hide comment
@npurushe

npurushe Mar 14, 2017

Contributor

Looks like your Android data binding class BR wasn't generated. Do you maybe have an error in your layout binding expressions?

Contributor

npurushe commented Mar 14, 2017

Looks like your Android data binding class BR wasn't generated. Do you maybe have an error in your layout binding expressions?

@kusyjan

This comment has been minimized.

Show comment
Hide comment
@kusyjan

kusyjan Mar 14, 2017

Hi. I have got same problem. I before android studio update and gradle update everything works fine, but when I update gradle to 3.3, requery won't generate BR class as @npurushe says.

kusyjan commented Mar 14, 2017

Hi. I have got same problem. I before android studio update and gradle update everything works fine, but when I update gradle to 3.3, requery won't generate BR class as @npurushe says.

@Seidak

This comment has been minimized.

Show comment
Hide comment
@Seidak

Seidak Mar 14, 2017

Hello I had the same problem, we have example project using data binding and after update we weren't able to build project anymore.

It looks like generated BR class is placed to different location than entity class. Because of that we are failing the build. Generated path to BR class cannot be resolved.

Seidak commented Mar 14, 2017

Hello I had the same problem, we have example project using data binding and after update we weren't able to build project anymore.

It looks like generated BR class is placed to different location than entity class. Because of that we are failing the build. Generated path to BR class cannot be resolved.

@npurushe

This comment has been minimized.

Show comment
Hide comment
@npurushe

npurushe Mar 14, 2017

Contributor

Can you specify what version of the android gradle plugin you update to that is causing the problem? thanks

Contributor

npurushe commented Mar 14, 2017

Can you specify what version of the android gradle plugin you update to that is causing the problem? thanks

@steelxtreme

This comment has been minimized.

Show comment
Hide comment
@steelxtreme

steelxtreme Mar 14, 2017

yeah, I know that BR class weren't generated, but happened after update build tools to 25.0.2 and gradle 3.3

steelxtreme commented Mar 14, 2017

yeah, I know that BR class weren't generated, but happened after update build tools to 25.0.2 and gradle 3.3

@npurushe

This comment has been minimized.

Show comment
Hide comment
@npurushe

npurushe Mar 15, 2017

Contributor

Did you also change the android gradle plugin version? I've tried 25.0.2 and gradle 3.4 with no issues, the gradle version shouldn't really affect it

Contributor

npurushe commented Mar 15, 2017

Did you also change the android gradle plugin version? I've tried 25.0.2 and gradle 3.4 with no issues, the gradle version shouldn't really affect it

@steelxtreme

This comment has been minimized.

Show comment
Hide comment
@steelxtreme

steelxtreme Mar 15, 2017

I had tried with gradle 3.4 with not success

here is my gradle config

`apply plugin: 'com.android.application'

android {
compileSdkVersion 25
buildToolsVersion '25.0.2'
defaultConfig {
applicationId "main.zlab.com.wayuu"
minSdkVersion 22
targetSdkVersion 22
versionCode 1
versionName "1.0"
// jackOptions {
// enabled true
// }
}
buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
}
}
lintOptions {
abortOnError false
disable 'InvalidPackage'
}

// compileOptions {
// sourceCompatibility JavaVersion.VERSION_1_8
// targetCompatibility JavaVersion.VERSION_1_8
// }
dataBinding {
enabled = true
}
sourceSets { main { assets.srcDirs = ['src/main/assets', 'src/main/res/assets/'] } }
productFlavors {
}
}

dependencies {
compile fileTree(include: ['*.jar'], dir: 'libs')
androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
exclude group: 'com.android.support', module: 'support-annotations'
})
compile 'com.android.support:support-annotations:25.2.0'
compile 'com.android.databinding:compiler:2.3.0'
testCompile 'junit:junit:4.12'
compile "io.reactivex:rxjava:1.2.0"

compile 'io.reactivex:rxandroid:1.2.1'
compile 'io.requery:requery:1.2.0'
compile 'io.requery:requery-android:1.2.0'
// for android
annotationProcessor 'io.requery:requery-processor:1.2.0'
compile 'com.android.support:support-annotations:25.2.0'
compile 'com.android.support:appcompat-v7:25.2.0'

}

`
and gradle wrapper

#Thu Mar 09 21:54:52 COT 2017 distributionBase=GRADLE_USER_HOME distributionPath=wrapper/dists zipStoreBase=GRADLE_USER_HOME zipStorePath=wrapper/dists distributionUrl=https\://services.gradle.org/distributions/gradle-3.4-all.zip

steelxtreme commented Mar 15, 2017

I had tried with gradle 3.4 with not success

here is my gradle config

`apply plugin: 'com.android.application'

android {
compileSdkVersion 25
buildToolsVersion '25.0.2'
defaultConfig {
applicationId "main.zlab.com.wayuu"
minSdkVersion 22
targetSdkVersion 22
versionCode 1
versionName "1.0"
// jackOptions {
// enabled true
// }
}
buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
}
}
lintOptions {
abortOnError false
disable 'InvalidPackage'
}

// compileOptions {
// sourceCompatibility JavaVersion.VERSION_1_8
// targetCompatibility JavaVersion.VERSION_1_8
// }
dataBinding {
enabled = true
}
sourceSets { main { assets.srcDirs = ['src/main/assets', 'src/main/res/assets/'] } }
productFlavors {
}
}

dependencies {
compile fileTree(include: ['*.jar'], dir: 'libs')
androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
exclude group: 'com.android.support', module: 'support-annotations'
})
compile 'com.android.support:support-annotations:25.2.0'
compile 'com.android.databinding:compiler:2.3.0'
testCompile 'junit:junit:4.12'
compile "io.reactivex:rxjava:1.2.0"

compile 'io.reactivex:rxandroid:1.2.1'
compile 'io.requery:requery:1.2.0'
compile 'io.requery:requery-android:1.2.0'
// for android
annotationProcessor 'io.requery:requery-processor:1.2.0'
compile 'com.android.support:support-annotations:25.2.0'
compile 'com.android.support:appcompat-v7:25.2.0'

}

`
and gradle wrapper

#Thu Mar 09 21:54:52 COT 2017 distributionBase=GRADLE_USER_HOME distributionPath=wrapper/dists zipStoreBase=GRADLE_USER_HOME zipStorePath=wrapper/dists distributionUrl=https\://services.gradle.org/distributions/gradle-3.4-all.zip

@npurushe

This comment has been minimized.

Show comment
Hide comment
@npurushe

npurushe Mar 17, 2017

Contributor

What's the package your BR file is generated in?

Contributor

npurushe commented Mar 17, 2017

What's the package your BR file is generated in?

@steelxtreme

This comment has been minimized.

Show comment
Hide comment
@steelxtreme

steelxtreme Mar 17, 2017

hi, this is the package

main.zlab.com.wayuu.repository.model

steelxtreme commented Mar 17, 2017

hi, this is the package

main.zlab.com.wayuu.repository.model

@steelxtreme

This comment has been minimized.

Show comment
Hide comment
@steelxtreme

steelxtreme Mar 24, 2017

I'm still facing this issue, any clue how to resolve it?

built using debug option:

12:31:07.939 [ERROR] [system.err] Note: processing adapters 12:31:07.940 [ERROR] [system.err] Note: building generational class cache 12:31:07.950 [ERROR] [system.err] Note: loaded item android.databinding.annotationprocessor.ProcessBindable$IntermediateV1@3a55ac0e from file 12:31:07.950 [ERROR] [system.err] Note: loaded item android.databinding.annotationprocessor.ProcessExpressions$IntermediateV2@742b373d from file 12:31:07.955 [ERROR] [system.err] Note: loaded item android.databinding.tool.store.SetterStore$IntermediateV3@334dc307 from file 12:31:07.955 [ERROR] [system.err] Note: wrote intermediate bindable file main.zlab.com.wayuu main.zlab.com.wayuu-setter_store.bin 12:31:07.956 [ERROR] [system.err] Note: SdkUtil init, minSdk: 22 12:31:07.956 [ERROR] [system.err] Note: wrote intermediate bindable file main.zlab.com.wayuu main.zlab.com.wayuu-layoutinfo.bin 12:31:07.956 [ERROR] [system.err] Note: reading resource bundle into data binder 12:31:07.957 [ERROR] [system.err] Note: writing file android.databinding.DataBindingComponent 12:31:07.957 [ERROR] [system.err] Note: checking if we have anything to generate. bundle size: 0 12:31:07.957 [ERROR] [system.err] Note: writing file android.databinding.DynamicUtil 12:31:07.957 [ERROR] [system.err] Note: wrote intermediate bindable file main.zlab.com.wayuu main.zlab.com.wayuu-br.bin 12:31:07.958 [ERROR] [system.err] Note: ************* Generating BR file main.zlab.com.wayuu. use final: APPLICATION 12:31:07.958 [ERROR] [system.err] Note: writing file main.zlab.com.wayuu.BR 12:31:07.958 [ERROR] [system.err] Note: writing file com.android.databinding.library.baseAdapters.BR 12:31:07.959 [ERROR] [system.err] Note: writing file android.databinding.DataBinderMapper 12:31:08.633 [ERROR] [system.err] /home/devquilla/AndroidStudioProjects/Wayuu/app/build/generated/source/apt/debug/main/zlab/com/wayuu/repository/model/DictionaryEntity.java:235: error: cannot find symbol 12:31:08.633 [ERROR] [system.err] notifyPropertyChanged(main.zlab.com.wayuu.repository.model.BR.word); 12:31:08.633 [ERROR] [system.err] ^ 12:31:08.633 [ERROR] [system.err] symbol: class BR 12:31:08.633 [ERROR] [system.err] location: package main.zlab.com.wayuu.repository.model 12:31:08.635 [ERROR] [system.err] /home/devquilla/AndroidStudioProjects/Wayuu/app/build/generated/source/apt/debug/main/zlab/com/wayuu/repository/model/DictionaryEntity.java:246: error: cannot find symbol 12:31:08.635 [ERROR] [system.err] notifyPropertyChanged(main.zlab.com.wayuu.repository.model.BR.definition); 12:31:08.635 [ERROR] [system.err] ^ 12:31:08.635 [ERROR] [system.err] symbol: class BR 12:31:08.635 [ERROR] [system.err] location: package main.zlab.com.wayuu.repository.model 12:31:08.637 [ERROR] [system.err] /home/devquilla/AndroidStudioProjects/Wayuu/app/build/generated/source/apt/debug/main/zlab/com/wayuu/repository/model/DictionaryEntity.java:257: error: cannot find symbol 12:31:08.637 [ERROR] [system.err] notifyPropertyChanged(main.zlab.com.wayuu.repository.model.BR.letra); 12:31:08.637 [ERROR] [system.err] ^ 12:31:08.637 [ERROR] [system.err] symbol: class BR 12:31:08.637 [ERROR] [system.err] location: package main.zlab.com.wayuu.repository.model 12:31:08.642 [ERROR] [system.err] 3 errors

steelxtreme commented Mar 24, 2017

I'm still facing this issue, any clue how to resolve it?

built using debug option:

12:31:07.939 [ERROR] [system.err] Note: processing adapters 12:31:07.940 [ERROR] [system.err] Note: building generational class cache 12:31:07.950 [ERROR] [system.err] Note: loaded item android.databinding.annotationprocessor.ProcessBindable$IntermediateV1@3a55ac0e from file 12:31:07.950 [ERROR] [system.err] Note: loaded item android.databinding.annotationprocessor.ProcessExpressions$IntermediateV2@742b373d from file 12:31:07.955 [ERROR] [system.err] Note: loaded item android.databinding.tool.store.SetterStore$IntermediateV3@334dc307 from file 12:31:07.955 [ERROR] [system.err] Note: wrote intermediate bindable file main.zlab.com.wayuu main.zlab.com.wayuu-setter_store.bin 12:31:07.956 [ERROR] [system.err] Note: SdkUtil init, minSdk: 22 12:31:07.956 [ERROR] [system.err] Note: wrote intermediate bindable file main.zlab.com.wayuu main.zlab.com.wayuu-layoutinfo.bin 12:31:07.956 [ERROR] [system.err] Note: reading resource bundle into data binder 12:31:07.957 [ERROR] [system.err] Note: writing file android.databinding.DataBindingComponent 12:31:07.957 [ERROR] [system.err] Note: checking if we have anything to generate. bundle size: 0 12:31:07.957 [ERROR] [system.err] Note: writing file android.databinding.DynamicUtil 12:31:07.957 [ERROR] [system.err] Note: wrote intermediate bindable file main.zlab.com.wayuu main.zlab.com.wayuu-br.bin 12:31:07.958 [ERROR] [system.err] Note: ************* Generating BR file main.zlab.com.wayuu. use final: APPLICATION 12:31:07.958 [ERROR] [system.err] Note: writing file main.zlab.com.wayuu.BR 12:31:07.958 [ERROR] [system.err] Note: writing file com.android.databinding.library.baseAdapters.BR 12:31:07.959 [ERROR] [system.err] Note: writing file android.databinding.DataBinderMapper 12:31:08.633 [ERROR] [system.err] /home/devquilla/AndroidStudioProjects/Wayuu/app/build/generated/source/apt/debug/main/zlab/com/wayuu/repository/model/DictionaryEntity.java:235: error: cannot find symbol 12:31:08.633 [ERROR] [system.err] notifyPropertyChanged(main.zlab.com.wayuu.repository.model.BR.word); 12:31:08.633 [ERROR] [system.err] ^ 12:31:08.633 [ERROR] [system.err] symbol: class BR 12:31:08.633 [ERROR] [system.err] location: package main.zlab.com.wayuu.repository.model 12:31:08.635 [ERROR] [system.err] /home/devquilla/AndroidStudioProjects/Wayuu/app/build/generated/source/apt/debug/main/zlab/com/wayuu/repository/model/DictionaryEntity.java:246: error: cannot find symbol 12:31:08.635 [ERROR] [system.err] notifyPropertyChanged(main.zlab.com.wayuu.repository.model.BR.definition); 12:31:08.635 [ERROR] [system.err] ^ 12:31:08.635 [ERROR] [system.err] symbol: class BR 12:31:08.635 [ERROR] [system.err] location: package main.zlab.com.wayuu.repository.model 12:31:08.637 [ERROR] [system.err] /home/devquilla/AndroidStudioProjects/Wayuu/app/build/generated/source/apt/debug/main/zlab/com/wayuu/repository/model/DictionaryEntity.java:257: error: cannot find symbol 12:31:08.637 [ERROR] [system.err] notifyPropertyChanged(main.zlab.com.wayuu.repository.model.BR.letra); 12:31:08.637 [ERROR] [system.err] ^ 12:31:08.637 [ERROR] [system.err] symbol: class BR 12:31:08.637 [ERROR] [system.err] location: package main.zlab.com.wayuu.repository.model 12:31:08.642 [ERROR] [system.err] 3 errors

@steelxtreme

This comment has been minimized.

Show comment
Hide comment
@steelxtreme

steelxtreme Mar 24, 2017

Update: I found BR class was generated at main.zlab.com.wayuu and DictionaryEntity class have a reference to : main.zlab.com.wayuu.repository.model.BR

Different packages.

steelxtreme commented Mar 24, 2017

Update: I found BR class was generated at main.zlab.com.wayuu and DictionaryEntity class have a reference to : main.zlab.com.wayuu.repository.model.BR

Different packages.

@indiv0

This comment has been minimized.

Show comment
Hide comment
@indiv0

indiv0 Mar 25, 2017

I'm having this issue as well, with the same symptoms. The BR class file is being generated in the root module, and not the model submodule (in my case).

EDIT: moving the model classes from the model submodule to the root module got the application compiling again, as a workaround.

indiv0 commented Mar 25, 2017

I'm having this issue as well, with the same symptoms. The BR class file is being generated in the root module, and not the model submodule (in my case).

EDIT: moving the model classes from the model submodule to the root module got the application compiling again, as a workaround.

@npurushe npurushe closed this in 6a54c26 Mar 25, 2017

@npurushe

This comment has been minimized.

Show comment
Hide comment
@npurushe

npurushe Mar 25, 2017

Contributor

This is caused by upgrading to Android gradle plugin 2.3 (com.android.tools.build:gradle:2.3.0).

In previous versions of the plugin the databinding package name (where the BR file is generated) was provided on an annotation in a generate file. In the new version it's passed as a annotation processor option which is now handled.

An updated version will be available soon, a temporary workaround is to simply use the previous android gradle plugin 2.2.2

Contributor

npurushe commented Mar 25, 2017

This is caused by upgrading to Android gradle plugin 2.3 (com.android.tools.build:gradle:2.3.0).

In previous versions of the plugin the databinding package name (where the BR file is generated) was provided on an annotation in a generate file. In the new version it's passed as a annotation processor option which is now handled.

An updated version will be available soon, a temporary workaround is to simply use the previous android gradle plugin 2.2.2

@npurushe npurushe added the bug label Mar 25, 2017

@steelxtreme

This comment has been minimized.

Show comment
Hide comment
@steelxtreme

steelxtreme Mar 27, 2017

Was Solved by adding in gradle

lintOptions {
abortOnError false
disable 'InvalidPackage'
}

and in proguard file :

-keep class * extends java.lang.Enum {
}
-dontwarn rx.internal.**
-dontwarn android.support.**

All based in latest android example in repo.

best regards.

steelxtreme commented Mar 27, 2017

Was Solved by adding in gradle

lintOptions {
abortOnError false
disable 'InvalidPackage'
}

and in proguard file :

-keep class * extends java.lang.Enum {
}
-dontwarn rx.internal.**
-dontwarn android.support.**

All based in latest android example in repo.

best regards.

@xorander00

This comment has been minimized.

Show comment
Hide comment
@xorander00

xorander00 Apr 7, 2017

Any update on this issue? I see the code change from alex-shpak.

xorander00 commented Apr 7, 2017

Any update on this issue? I see the code change from alex-shpak.

@consp1racy

This comment has been minimized.

Show comment
Hide comment
@consp1racy

consp1racy Apr 8, 2017

Contributor

Hello @xorander00, If there were any updates on the issue THEY WOULD BE POSTED HERE. Besides it's weekend.

Contributor

consp1racy commented Apr 8, 2017

Hello @xorander00, If there were any updates on the issue THEY WOULD BE POSTED HERE. Besides it's weekend.

@xorander00

This comment has been minimized.

Show comment
Hide comment
@xorander00

xorander00 Apr 8, 2017

@consp1racy Just pinging for a status update because I'm going to make some local changes and didn't want to waste time doing duplicate work. No harm, no foul.

Also, I work weekends.

xorander00 commented Apr 8, 2017

@consp1racy Just pinging for a status update because I'm going to make some local changes and didn't want to waste time doing duplicate work. No harm, no foul.

Also, I work weekends.

@npurushe

This comment has been minimized.

Show comment
Hide comment
@npurushe

npurushe Apr 10, 2017

Contributor

version 1.3.0 contains this fix

Contributor

npurushe commented Apr 10, 2017

version 1.3.0 contains this fix

@xorander00

This comment has been minimized.

Show comment
Hide comment
@xorander00

xorander00 Apr 10, 2017

Excellent! I just updated and it looks to be working fine. Great work, loving the project man :)

Quick & dumb question, but...when performing a query using EntityDataStore, does it automatically return the connection to the pool or does my code need to be explicit about that?

I'm using requery on both my Java server-side project as well as client-side Android project. It's working fine on Android, but on my server project it exhausts the connection pool after running for a while. It looks like none of the connections are being returned, so I'm wondering what it is that I'm missing.

xorander00 commented Apr 10, 2017

Excellent! I just updated and it looks to be working fine. Great work, loving the project man :)

Quick & dumb question, but...when performing a query using EntityDataStore, does it automatically return the connection to the pool or does my code need to be explicit about that?

I'm using requery on both my Java server-side project as well as client-side Android project. It's working fine on Android, but on my server project it exhausts the connection pool after running for a while. It looks like none of the connections are being returned, so I'm wondering what it is that I'm missing.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment