New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't compile with AndroidX and Databinding #835

Closed
zsavely opened this Issue Nov 23, 2018 · 1 comment

Comments

Projects
None yet
2 participants
@zsavely

zsavely commented Nov 23, 2018

Android Gradle Plugin 3.2.1
Kotlin 1.3.10
Requery 1.5.1
gradle.properties is

android.enableJetifier=true
android.useAndroidX=true

Requery generates databinding helper calls but imports android.databinding.BaseObservable which is not available in AndroidX packages.

> Transform requery-processor.jar (io.requery:requery-processor:1.5.1) with JetifyTransform
> Task :app:dataBindingExportFeaturePackageIdsDebug UP-TO-DATE
> Task :app:kaptGenerateStubsDebugKotlin
e: /Users/szagurskii/AndroidStudioProjects/TestProject/app/build/generated/source/kapt/debug/com/example/szagurskii/testproject/PhoneEntity.java:4: error: cannot find symbol
import android.databinding.BaseObservable;
                          ^
  symbol:   class BaseObservable
  location: package android.databinding
e: /Users/szagurskii/AndroidStudioProjects/TestProject/app/build/generated/source/kapt/debug/com/example/szagurskii/testproject/PhoneEntity.java:26: error: cannot find symbol
public class PhoneEntity extends BaseObservable implements Phone, Persistable, Parcelable {
                                 ^
  symbol: class BaseObservable
> Task :app:kaptDebugKotlin FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:kaptDebugKotlin'.
> Compilation error. See log for more details

@npurushe npurushe self-assigned this Nov 25, 2018

@npurushe npurushe closed this in e209295 Nov 27, 2018

@npurushe

This comment has been minimized.

Contributor

npurushe commented Nov 27, 2018

This will be supported in the next release

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment