Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

ver >=2.9.150 broke my stuff :( #189

Closed
jmonster opened this Issue · 4 comments

3 participants

@jmonster

reverted back to 2.9.100 and it worked again. will post more information when i figure it out. For now, here's a stack trace

at /Users/jmonster/Downloads/BB/transcoder/encore/encore.js:33:15
at /Users/jmonster/Downloads/BB/transcoder/encore/encore.js:118:3
at /Users/jmonster/Downloads/BB/transcoder/transcoder.js/node_modules/caching/lib/caching.js:26:12
at Array.forEach (native)
at /Users/jmonster/Downloads/BB/transcoder/transcoder.js/node_modules/caching/lib/caching.js:25:18
at /Users/jmonster/Downloads/BB/transcoder/encore/encore.js:112:4
at Request._callback (/Users/jmonster/Downloads/BB/transcoder/encore/encore.js:145:4)
at Request.callback (/Users/jmonster/Downloads/BB/transcoder/encore/node_modules/request/main.js:111:22)
at Request.<anonymous> (/Users/jmonster/Downloads/BB/transcoder/encore/node_modules/request/main.js:442:16)
@mikeal
Owner

this is the stack but it's lacking the actual exception.

i fixed a bug yesterday with 2.9.150 that was auto-decoding all responses as JSON that might have caused it so please try the very latest version and also please give me the exception that was thrown, it may be enough on it's own to figure this out.

@wavded

@mikeal is there a way to turn off auto-decoding of JSON?

@wavded

nvm, found it json: false, I'm guessing this default changed recently, cause that's what blew up my stuff :)

@mikeal
Owner

actually, auto-decoding json was a bug that is now fixed :)

@mikeal mikeal closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.