HTTPS Tunneling requires node >=0.6.11 #202

Closed
vpulim opened this Issue Mar 9, 2012 · 3 comments

Comments

Projects
None yet
2 participants
@vpulim

vpulim commented Mar 9, 2012

When trying to use the new tunneling code with a pre 0.6.11 version of node, an error should probably be thrown in createSecureSocket() in tunnel.js that lets the user know that node >=0.6.11 is required to do httpsOverHttp or httpsOverHttps.

To do tunneling in pre-0.6.11 node, you can also try: https://github.com/milewise/node-https-proxied

@mikeal

This comment has been minimized.

Show comment Hide comment
@mikeal

mikeal Mar 9, 2012

Member

what is in 0.6.11 that we need that isn't in 0.6.10?

Member

mikeal commented Mar 9, 2012

what is in 0.6.11 that we need that isn't in 0.6.10?

@vpulim

This comment has been minimized.

Show comment Hide comment
@vpulim

vpulim Mar 10, 2012

starting from node 0.6.11 tls.connect() takes a new socket option that lets you convert a cleartext socket to an encrypted socket. that's why koichik's node-tunnel package has an engine requirement of "node": ">=0.6.11 <=0.7.0 || >=0.7.3" in its package.json.

vpulim commented Mar 10, 2012

starting from node 0.6.11 tls.connect() takes a new socket option that lets you convert a cleartext socket to an encrypted socket. that's why koichik's node-tunnel package has an engine requirement of "node": ">=0.6.11 <=0.7.0 || >=0.7.3" in its package.json.

@mikeal

This comment has been minimized.

Show comment Hide comment
@mikeal

mikeal Jul 25, 2012

Member

do this just silently fail or does it fail really badly?

Member

mikeal commented Jul 25, 2012

do this just silently fail or does it fail really badly?

@mikeal mikeal closed this Jul 25, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment