Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Installation issue on windows 7 x64 #439

Closed
Xelom opened this Issue Feb 22, 2013 · 3 comments

Comments

Projects
None yet
2 participants

Xelom commented Feb 22, 2013

I tried to install request by npm install request but getting following error everytime:

Npm Log:
error contextify@0.1.4 install: node-gyp rebuild
error cmd "/c" "node-gyp rebuild" failed with 1
error Failed at the contextify@0.1.4 install script.
error This is most likely a problem with the contextify package,
error not with npm itself.
error Tell the author that this fails on your system:
error node-gyp rebuild
error You can get their info via:
error npm owner ls contextify
error There is likely additional logging output above.
error System Windows_NT 6.1.7601
error command "C:\Program Files\nodejs\node.exe" "C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js" "install" "jsdom"
error cwd C:\Arıl\Node\scrap2
error node -v v0.8.16
error npm -v 1.1.69
error code ELIFECYCLE
verbose exit [ 1, true ]

Command Line:
gyp ERR! configure error
gyp ERR! stack Error: gyp failed with exit code: 1
gyp ERR! stack at ChildProcess.onCpExit (C:\Program Files\nodejs\node_module
s\npm\node_modules\node-gyp\lib\configure.js:395:16)
gyp ERR! stack at ChildProcess.EventEmitter.emit (events.js:99:17)
gyp ERR! stack at Process._handle.onexit (child_process.js:678:10)
gyp ERR! System Windows_NT 6.1.7601
gyp ERR! command "node" "C:\Program Files\nodejs\node_modules\npm\node_modu
les\node-gyp\bin\node-gyp.js" "rebuild"
gyp ERR! cwd C:\Aril\Node\scrap2\node_modules\jsdom\node_modules\contextify
gyp ERR! node -v v0.8.16
gyp ERR! node-gyp -v v0.7.3
gyp ERR! not ok
npm ERR! contextify@0.1.4 install: node-gyp rebuild
npm ERR! cmd "/c" "node-gyp rebuild" failed with 1
npm ERR!
npm ERR! Failed at the contextify@0.1.4 install script.
npm ERR! This is most likely a problem with the contextify package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get their info via:
npm ERR! npm owner ls contextify
npm ERR! There is likely additional logging output above.

npm ERR! System Windows_NT 6.1.7601
npm ERR! command "C:\Program Files\nodejs\node.exe" "C:\Program Files\nod
ejs\node_modules\npm\bin\npm-cli.js" "install" "jsdom"
npm ERR! cwd C:\Aril\Node\scrap2
npm ERR! node -v v0.8.16
npm ERR! npm -v 1.1.69
npm ERR! code ELIFECYCLE
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! C:\Aril\Node\scrap2\npm-debug.log
npm ERR! not ok code 0

I can see it is not a problem with request but contexify. Since you are using it as a dependency this is stopping the installation progress. I don't have any information about it is happening in other operating systems.

Node Version: v0.8.16
Npm Version: 1.1.69

Owner

mikeal commented Feb 22, 2013

this is an install issue with contextify in node-gyp. this is not a request bug, request isn't compiled and has no compiled dependencies so a gyp failure could never happen.

@mikeal mikeal closed this Feb 22, 2013

Xelom commented Feb 22, 2013

Thanks mikeal. Can you lead me to somewhere I can open an issue about this?

Owner

mikeal commented Feb 22, 2013

https://github.com/brianmcd/contextify

On Feb 22, 2013, at February 22, 20133:15 PM, Xelom notifications@github.com wrote:

Thanks mikeal. Can you lead me to somewhere I can open an issue about this?


Reply to this email directly or view it on GitHub.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment