Skip to content
Compare
Choose a tag to compare

Extra compatibility with requirejs, tracked in the fixed issues.

Compare
Choose a tag to compare

Ports fixes from requirejs 2.3 so that alameda passes the requirejs 2.3 tests, except for the ones previously noted as unsupported.

Compare
Choose a tag to compare

Ports fixes from requirejs 2.2 so that alameda passes the requirejs 2.2 tests, except for the ones previously noted as unsupported.

Compare
Choose a tag to compare

Main issue was restoring the errback behavior to match requirejs. 0.3.0 did something different, but this release restores the previous behavior.

Compare
Choose a tag to compare

With the 0.3.0 release, the work started in the native-promise branch has been moved into the master branch. This means alameda only works in JS environments with native promise support.

For those that need to support IE 10 and 11, try alameda-prim, which bundles a private Promise implementation to allow alameda to work in those environments.