Browse files

Change jquery-rails requirement to ~> 2.0.0 before running bundle ins…

…tall initially.
  • Loading branch information...
1 parent 97b6f8d commit 3239c553ddcf31081d8f4985be2550928a1e5f37 @robyurkowski robyurkowski committed Aug 18, 2012
Showing with 6 additions and 3 deletions.
  1. +4 −1 changelog.md
  2. +1 −1 templates/refinery/edge.rb
  3. +1 −1 templates/refinery/installer.rb
View
5 changelog.md
@@ -7,7 +7,10 @@
* [See full list](https://github.com/resolve/refinerycms/compare/2-0-stable...master)
-## 2.0.7 [Unreleased]
+## 2.0.8 [17 August 2012]
+* Fixes installs broken by the release of jquery-rails 2.1.0 by requiring ~> 2.0.0. [Rob Yurkowski](https://github.com/robyurkowski)
+
+## 2.0.7 [16 August 2012]
* Fixed a bug with nested reordering that would shuffle any set with 11 or more entities. [#1882](https://github.com/resolve/refinerycms/pull/1882). [Rob Yurkowski](https://github.com/robyurkowski)
## 2.0.6 [6 August 2012]
View
2 templates/refinery/edge.rb
@@ -1,5 +1,6 @@
require 'rbconfig'
+gsub_file 'Gemfile', "gem 'jquery-rails'", "gem 'jquery-rails', '~> 2.0.0'"
# We want to ensure that you have an ExecJS runtime available!
begin
run 'bundle install'
@@ -9,7 +10,6 @@
gsub_file 'Gemfile', "# gem 'therubyracer'", "gem 'therubyracer'"
end
-gsub_file 'Gemfile', "gem 'jquery-rails'", "gem 'jquery-rails', '~> 2.0.0'"
append_file 'Gemfile' do
"
View
2 templates/refinery/installer.rb
@@ -1,6 +1,7 @@
require 'rbconfig'
VERSION_BAND = '2.0.0'
+gsub_file 'Gemfile', "gem 'jquery-rails'", "gem 'jquery-rails', '~> 2.0.0'"
# We want to ensure that you have an ExecJS runtime available!
begin
run 'bundle install'
@@ -21,7 +22,6 @@
end
end
-gsub_file 'Gemfile', "gem 'jquery-rails'", "gem 'jquery-rails', '~> 2.0.0'"
append_file 'Gemfile', <<-GEMFILE
# Refinery CMS

0 comments on commit 3239c55

Please sign in to comment.