Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error report submission is very slow. #1002

Closed
sati-bodhi opened this issue Jun 26, 2018 · 144 comments

Comments

@sati-bodhi
Copy link

commented Jun 26, 2018

This is a follow-up of the author's attribute discussion on Zotero Forums.

It has been proposed that Creator: Last || First A. || Type format support should be added to BBT so that users can define their own authors' attributes that map to the authortype field in Bibtex via the Zotero Extra field.

This feature would be useful particularly for academics who write and cite works in Chinese, as elaborated over here.

@retorquere

This comment has been minimized.

Copy link
Owner

commented Jun 26, 2018

Can you right-click a reference that has this and select "BBT -> Error report" (paste the resulting ID here). After that, please also paste here how you would like the biblatex to look like.

@retorquere

This comment has been minimized.

Copy link
Owner

commented Jun 26, 2018

Did you right-click the whole library (that could take a while) or just those that one reference (should be really quick)?

@sati-bodhi

This comment has been minimized.

Copy link
Author

commented Jun 26, 2018

I clicked just one reference - the one I illustrated above. It took ages the last time I tried to submit one as well. I think that one didn't pull through...

@retorquere

This comment has been minimized.

Copy link
Owner

commented Jun 26, 2018

I don't know why it's so slow for you -- I just tried to submit a report for a single ref and it's near instantaneous.

I honestly have no idea what that stackexchange link tries to explain. I don't understand biblatex as well as some would assume.

@njbart?

@sati-bodhi

This comment has been minimized.

Copy link
Author

commented Jun 26, 2018

Zotero says 'Network error' when I force it to shutdown after being unresponsive for a while.

default

Just posted this as a separate issue on Zotero Forums.

@sati-bodhi

This comment has been minimized.

Copy link
Author

commented Jun 26, 2018

It doesn't seem to work. Can I just attach a file with text from the error report over here?

@retorquere

This comment has been minimized.

Copy link
Owner

commented Jun 26, 2018

Sure, if it's just a .txt file. But can you try downloading https://github.com/retorquere/zotero-better-bibtex/releases/download/release/error-report.html, opening it, and submitting your file through that? That should do the same, I'm curious to see why you can't submit logs as per usual. The upload through this won't give any feedback unless there's an error though.

@sati-bodhi

This comment has been minimized.

Copy link
Author

commented Jun 26, 2018

It's done.
Generated on 20180626T000153Z

@retorquere

This comment has been minimized.

Copy link
Owner

commented Jun 26, 2018

Nothing out of the ordinary in the log. I'm actually looking for an export using BetterBibTeX JSON. That's what BBT does when you submit an error log by right-clicking a reference.

@sati-bodhi

This comment has been minimized.

Copy link
Author

commented Jun 26, 2018

Is there anything else I need to do?

dstillman says that:

BBT issues should be reported to the BBT developer on GitHub.

on the Zotero forum where I reported the submission issue...


Just to double-check to make sure I am doing this correctly:

default

This is what I am supposed to do, right?

@retorquere

This comment has been minimized.

Copy link
Owner

commented Jun 26, 2018

Wrt the error submission, please enable extended debugging, and try to submit a bbt error log from the help menu. If it doesn't work, save the log contents to a text file and attach it here.

@retorquere

This comment has been minimized.

Copy link
Owner

commented Jun 26, 2018

that screenshot is correct. Does the error submission screen not come up?

@retorquere

This comment has been minimized.

Copy link
Owner

commented Jun 26, 2018

If author type isn't actually commonly used, perhaps the stackexchange answer is better. But I don't know what's proposed there, really.

@sati-bodhi

This comment has been minimized.

Copy link
Author

commented Jun 26, 2018

The Debug ID is D720330192.

Error submission screen did came up, but I kept getting stuck here.

default

The above error ID is from the help menu.

@sati-bodhi

This comment has been minimized.

Copy link
Author

commented Jun 26, 2018

Then this error popped up:

default

@retorquere

This comment has been minimized.

Copy link
Owner

commented Jun 26, 2018

That ID is for reports sent to Zotero, I can't read those. You need to use "Help->Report Better BibTeX Errors".

@retorquere

This comment has been minimized.

Copy link
Owner

commented Jul 10, 2018

Your DB allowed me to do some necessary performance work BTW -- try 7587.

@sati-bodhi

This comment has been minimized.

Copy link
Author

commented Jul 11, 2018

default

It says 7579 is incompatible with my current version of Zotero.

@sati-bodhi

This comment has been minimized.

Copy link
Author

commented Jul 11, 2018

WGE5RX4-apse
C2DNQ4MA-apse

These are from 7587. Time taken for the subsequent submission has improved significantly.

@retorquere

This comment has been minimized.

Copy link
Owner

commented Jul 11, 2018

I'd say. Minute and a half if my calculations are correct? The speed is most likely attributable to the better way to assemble the logs I have implemented.

Still some puzzling things though:

  • this is still way too slow. You're uploading just 5.5 MB of data
  • you're not making use of the speedup I had implemented using parallel uploads, because that kicks in when the upload is larger than 10MB
  • WGE5RX4-apse and C2DNQ4MA-apse differ in size only by a few Kb, and if anything, WGE5RX4 should have been faster because it's smaller.
@retorquere

This comment has been minimized.

Copy link
Owner

commented Jul 11, 2018

I don't know why 7579 won't install; 7579 was tested automatically against Zotero 5.0.53 before release, so if it was incompatible with 5.0.53 all the tests would have failed and the release could not have gone out. If you look at the download that you have, can it be that it is a HTML file rather than a XPI? Maybe you downloaded the download page rather than the XPI?

@sati-bodhi

This comment has been minimized.

Copy link
Author

commented Jul 11, 2018

It's done.
I think the last download was incomplete, which led to the error.

UAWUUVG4-apse
B69IAL8Y-euc

from 7579

@blip-bloop

This comment has been minimized.

Copy link
Collaborator

commented Jul 11, 2018

🤖 this is your friendly neighborhood build bot announcing test build 5.0.164.7594 ("configurable debug log").

@retorquere

This comment has been minimized.

Copy link
Owner

commented Jul 11, 2018

On 7594, try setting the preference debugLog to 1 to see of that speeds things up.

@blip-bloop

This comment has been minimized.

Copy link
Collaborator

commented Jul 11, 2018

🤖 this is your friendly neighborhood build bot announcing test build 5.0.164.7602 ("a little overzealous on pref hiding").

@retorquere

This comment has been minimized.

Copy link
Owner

commented Jul 11, 2018

7602 should be a tad faster still. I'm not sure whether debugLog = 1 will make much of a difference (it doesn't for me), but still curious to know.

If @blip-bloop announces a new version, you can skip all the previous ones unless I specifically ask to test an older one.

@sati-bodhi

This comment has been minimized.

Copy link
Author

commented Jul 11, 2018

I cannot find debugLog on the preference pane.

default

@retorquere

This comment has been minimized.

Copy link
Owner

commented Jul 11, 2018

It's not, sorry, it's a hidden preference.

@blip-bloop

This comment has been minimized.

Copy link
Collaborator

commented Jul 12, 2018

🤖 this is your friendly neighborhood build bot announcing test build 5.0.169.7656 ("remove dbg prefix").

@retorquere

This comment has been minimized.

Copy link
Owner

commented Jul 12, 2018

7656 should have a marked increase in speed for debug submission

@blip-bloop

This comment has been minimized.

Copy link
Collaborator

commented Jul 14, 2018

🤖 this is your friendly neighborhood build bot announcing test build 5.0.170.7702 ("jurism being different").

@retorquere

This comment has been minimized.

Copy link
Owner

commented Jul 15, 2018

assuming fixed

@sati-bodhi

This comment has been minimized.

Copy link
Author

commented Jul 16, 2018

ZVBZDVZS-euc
AWZVVTHN-apse

This is from 7656. It is remarkably faster, indeed! Thank you for your kind assistance.

@label-gun label-gun bot reopened this Jul 16, 2018
@retorquere

This comment has been minimized.

Copy link
Owner

commented Jul 16, 2018

"Can it work" is ambiguous between "do the laws of logic/physics prohibit" and "can it currently" and "can it sensibly be made to", to which the answers are no, no, and not really.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.