Rework plugin to check if CSS contains more selectors than allowed by IE < 10's selector limit
JavaScript
Latest commit fe24442 Jun 24, 2014 @necolas necolas Use 'rework' ^1.0.0 in dev
Permalink
Failed to load latest commit information.
test
.gitignore
.travis.yml
CHANGELOG.md
LICENSE.md
README.md
index.js
package.json

README.md

rework-ie-limits

Build Status

A Rework plugin that tests whether a chunk of CSS exceeds IE < 10's limit of 4095 selectors.

Installation

Install with npm:

npm install rework-ie-limits

Use

As a Rework plugin:

var rework = require('rework');
var ieLimits = require('rework-ie-limits');

var css = rework(cssinput).use(ieLimits);

It will throw an Error if the limit has been exceeded.

Note that the plugin is extremely conservative. It will assume that ALL selectors (and those within any media query) are supported and applied by each version of IE < 10. Therefore, there will be some false positives as you approach the limit.

Testing

For CI:

npm test

For development:

npm run watch