Skip to content
Elephant Trade Information System
Ruby R JavaScript Other
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
app
config Download features and bugfixes Aug 3, 2012
db Release candidate May 20, 2012
doc
etl
lib
public
r
script
test
vendor/plugins
.gitignore
.gitmodules
COPYING
Capfile
Gemfile
Gemfile.lock
Procfile
README Initial commit Jul 14, 2011
Rakefile
config.ru

README

ETIS
====


Introduction
------------

This application is the Rails framework for the next generation
version of the Elephant Trade Information System (ETIS).

For more information about the ETIS 2011 project, see

http://www.assembla.com/spaces/etis

An account may be required.  For access, contact:
f.m.underwood@ac.reading.uk


Dependencies
------------

The Ruby programming language runtime, version 1.9.2 or later.

The R programming language, version 2.12.0 or later.

PostgreSQL, version 8.4 or later.


Getting Started
---------------

After installing the dependencies above, create the necessary databases
in the local postgresql server.  See or modify db/config.yaml for the
database connection parameters. Environment variables are used to
exclude passwords from the repository; please set the appropriate
environment variables and do not modify the config.yaml settings.

Run:

    rake db:schema:load

to create a functional, but empty, ETIS development system.

To work with production data, you must demonstrate a qualified usage and
execute a data access agreement.  Production data will be provided as a
PostgreSQL dump file in SQL format, which you can load with

    psql [database-name] [options] < [dump-file-name]


License
-------

The source of this application is made available under the GNU General
Public License, Version 3. A copy of that license is available in the
file COPYING.
You can’t perform that action at this time.