Skip to content
Safely print shared library dependencies (similar to ldd)
Shell
Find file
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
README.textile
lddsafe

README.textile

NAME

lddsafe — Safely print shared library dependencies (similar to ldd)

DESCRIPTION

lddsafe is a shell script written for Linux distributions (tested under Slackware Linux) that prints shared library dependencies for executable files and shared libraries, similar to ldd. However, it uses objdump instead of loading the program, hence avoiding the security problems of ldd.

REQUIREMENTS

The most notable requirement of lddsafe is that it needs bash version 4 or later.

BUG REPORTS

Please, do not hesitate to point out possible improvements and ways to make the script work on systems which it currently may not work.

Something went wrong with that request. Please try again.