Skip to content
Commits on Jan 15, 2016
  1. @teeparham

    Version 3.1.3

    teeparham committed
  2. @teeparham

    Restrict activerecord dependency to 4.2

    teeparham committed
    There are breaking changes in Rails 5. Support for Rails 5 will be
    added to master in version 4.x of this adapter.
    
    Support for activerecord 4.2 will be continued in the v3.0-stable
    branch, which will correspond to version 3.x of this adapter.
    
    * Revert 787bfab
Commits on Dec 29, 2015
  1. @teeparham

    Version 3.1.2

    teeparham committed
  2. @teeparham
  3. @teeparham

    Revert "Fix rgeo-activerecord require"

    teeparham committed
    This reverts commit bc9421f.
Commits on Dec 28, 2015
  1. @teeparham

    Update release notes [ci skip]

    teeparham committed
  2. @teeparham

    Version 3.1.1

    teeparham committed
  3. @teeparham

    Add 3.1.1 notes, fix typos

    teeparham committed
  4. @teeparham

    Fix rgeo-activerecord require

    teeparham committed
Commits on Dec 25, 2015
  1. @teeparham
Commits on Dec 20, 2015
  1. @teeparham

    Merge pull request #203 from rgeo/rubocop

    teeparham committed
    Add Rubocop, correct style violations
  2. @teeparham

    [style] Parens

    teeparham committed
  3. @teeparham

    [style] Delimiters

    teeparham committed
  4. @teeparham
  5. @teeparham

    [style] Quotes

    teeparham committed
  6. @teeparham
  7. @teeparham

    Remove tmp files

    teeparham committed
  8. @teeparham

    [style] Hashes

    teeparham committed
  9. @teeparham

    [style] Indentation

    teeparham committed
  10. @teeparham

    [style] Empty lines

    teeparham committed
  11. @teeparham
  12. @teeparham
  13. @teeparham

    Add .rubocop.yml

    teeparham committed
Commits on Nov 19, 2015
  1. @teeparham

    Version 3.1.0

    teeparham committed
  2. @teeparham

    Update version history

    teeparham committed
  3. @teeparham
  4. @teeparham
  5. @deivid-rodriguez
  6. @teeparham

    Merge pull request #200 from rgeo/no-sudo

    teeparham committed
    Upgrade to new Travis container builds
  7. @teeparham
  8. @deivid-rodriguez

    I don't think we need "19 mode"

    deivid-rodriguez committed
    JRuby 1.7.x is "1.9" compatible by default. Let's just use "jruby-1.7" and let
    `rvm` match that against the latest available patch level version.
  9. @deivid-rodriguez
  10. @deivid-rodriguez

    Don't test activerecord internals

    deivid-rodriguez committed
    While in MRI default values kept in the `columns` array are always
    quoted, in JRuby, they are resolved to the correct type. Since the
    following test already checks for user expectation (correct default when
    creating an object), I just removed the failing test.
  11. @deivid-rodriguez

    Don't use driver internals for tests

    deivid-rodriguez committed
    The `result_status` method is not provided by the Java driver. This
    assertion was added in e4e3442, and the
    intention was only to simplify the test, so I think we're fine reverting
    that specific change.
  12. @teeparham

    Update readme [ci skip]

    teeparham committed
Something went wrong with that request. Please try again.