Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Node 0.5.x/0.6.x compatibility.

  • Loading branch information...
commit 3ce71bd3d22076ea349ce1ed0251383801d3362f 1 parent f6de620
@rgrove authored
Showing with 15 additions and 14 deletions.
  1. +6 −0 HISTORY.md
  2. +0 −6 bin/selleck
  3. +9 −8 package.json
View
6 HISTORY.md
@@ -1,6 +1,12 @@
Selleck History
===============
+0.1.7 (git)
+-----------
+
+* Node 0.5.x/0.6.x compatibility.
+
+
0.1.6 (2011-09-27)
------------------
View
6 bin/selleck
@@ -95,11 +95,7 @@ while ((arg = argv.shift())) {
case '--help':
case '-h':
- // WTF. This is seriously the only way I've been able to figure out to
- // make Node reliably flush to stdout before exiting. It's ridiculous.
- // This is stupid.
process.stdout.write(help);
- while (!process.stdout.flush()) {};
process.exit();
break;
@@ -175,9 +171,7 @@ while ((arg = argv.shift())) {
""
].join('\n');
- // See rant above re. forcing Node to flush stdout before exiting.
process.stdout.write(version);
- while (!process.stdout.flush()) {};
process.exit();
break;
View
17 package.json
@@ -2,7 +2,7 @@
"name" : "selleck",
"description": "Generator for YUI's Handlebars-based user documentation.",
- "version" : "0.1.6",
+ "version" : "0.1.7-git",
"homepage" : "https://github.com/rgrove/selleck/",
"author" : "Ryan Grove <ryan@wonko.com> (http://wonko.com/)",
"copyright" : "Copyright (c) 2011 Yahoo! Inc. All rights reserved.",
@@ -10,20 +10,21 @@
"keywords" : ["yui", "handlebars", "mustache", "docs", "documentation"],
"licenses": [
- {"type": "BSD", "url": "http://developer.yahoo.com/yui/license.html"}
+ {"type": "BSD", "url": "http://yuilibrary.com/license/"}
],
- "repository": [
- {"type": "git", "url": "git://github.com/rgrove/selleck.git"}
- ],
+ "repository": {
+ "type": "git",
+ "url" : "git://github.com/rgrove/selleck.git"
+ },
"engines": [
- "node ~0.4.0",
- "npm >=0.3.1 <1.1.0"
+ "node 0.4 || 0.5 || 0.6",
+ "npm ~1.0.0"
],
"dependencies": {
- "express" : ">=2.3.0 <2.5.0"
+ "express" : ">=2.3.0 <2.6.0",
},
"main": "index",
Please sign in to comment.
Something went wrong with that request. Please try again.