Permalink
Browse files

Update Debian packaging

- fix broken depends
- use dh_python2
- drop useless debian/pyversions
- do not install git.log files instead of removing them
- add me as maintainer
  • Loading branch information...
1 parent c8d1f2e commit da2f430f7de0eff4c9fde932b463398064e8a37f @rhertzog committed Sep 20, 2012
Showing with 9 additions and 9 deletions.
  1. +1 −1 debian/compat
  2. +5 −4 debian/control
  3. +0 −1 debian/pyversions
  4. +3 −3 debian/rules
View
@@ -1 +1 @@
-8
+9
View
@@ -1,9 +1,10 @@
Source: librement
Section: net
Priority: optional
-Maintainer: Chris Lamb <chris@lambynet.co.uk>
-Build-Depends: debhelper (>= 8)
-Standards-Version: 3.9.2
+Maintainer: Raphaël Hertzog <raphael@freexian.com>
+Uploaders: Chris Lamb <chris@lambynet.co.uk>
+Build-Depends: debhelper (>= 9), python (>= 2.6.6-3~)
+Standards-Version: 3.9.3
Package: librement
Architecture: all
@@ -13,6 +14,6 @@ Depends:
python-bcrypt,
python-django,
python-django-south,
- python-imaging.
+ python-imaging,
python-psycopg2,
python-feedparser,
View
@@ -1 +0,0 @@
-2.6-
View
@@ -3,10 +3,10 @@
export PYTHONDONTWRITEBYTECODE = 1
%:
- dh $@
+ dh $@ --with python2
-override_dh_auto_clean:
- rm -f src/contrib/*/*.log
+override_dh_install:
+ dh_install -Xgit.log
override_dh_auto_test:
src/librement/manage.py test --verbosity=2

0 comments on commit da2f430

Please sign in to comment.