Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

fix app ceate

  • Loading branch information...
commit a1eb17d406778b9af60b3232435b45db42a2ed48 1 parent ef4ba93
authored July 03, 2012
2  example/public/js/application.js
@@ -39,7 +39,7 @@ function setToken(){
39 39
 
40 40
 function createApp(){
41 41
 	var name     = $('#app-name').val();
42  
-	var app_type = $('input[name=group1]:checked', '#appcreateform').val();
  42
+	var app_type = $('input[name=group2]:checked', '#appcreateform').val();
43 43
 	start_request("create-app-submit", "create-app-status");
44 44
 	$.ajax({
45 45
 		  type: 'POST',
6  lib/rhohub/build.rb
@@ -2,9 +2,9 @@ class Rhohub::Build < Rhohub::Base
2 2
   
3 3
   def self.create(options,data)
4 4
     catch_all do
5  
-      raise Exception.new "missing target_device" unless data['target_device'] 
6  
-      raise Exception.new "missing version_tag" unless data['version_tag'] 
7  
-      raise Exception.new "missing rhodes_version"  unless data['rhodes_version'] 
  5
+      raise Exception.new "missing target_device" unless data[:build]['target_device'] 
  6
+      raise Exception.new "missing version_tag" unless data[:build]['version_tag'] 
  7
+      raise Exception.new "missing rhodes_version"  unless data[:build]['rhodes_version'] 
8 8
       raise Exception.new "missing app_id" unless options[:app_id]
9 9
       super(options,data,'builds')
10 10
     end

1 note on commit a1eb17d

Lars Burgess
Collaborator

This commit broke the build with:

  1) Rhohub::Build should make a POST request to create build
     Failure/Error: Rhohub::Build.create({:app_id => 4},{'target_device'=>"Android", 'version_tag' => 'master', 'rhodes_version' => 'master' })
     ArgumentError:
       uncaught throw :halt
     # ./lib/rhohub/base.rb:9:in `throw'
     # ./lib/rhohub/base.rb:9:in `rescue in catch_all'
     # ./lib/rhohub/base.rb:4:in `catch_all'
     # ./lib/rhohub/build.rb:4:in `create'
     # ./spec/build_spec.rb:21:in `block (2 levels) in <top (required)>'
Please sign in to comment.
Something went wrong with that request. Please try again.