Skip to content
This repository
Browse code

switch to gemfile

  • Loading branch information...
commit a5dde4cfb0bf9e9d72ea690a16e41b91301fce89 1 parent 62f590c
Oren Teich authored
4  .gems
... ...
@@ -1,4 +0,0 @@
1  
-rdiscount
2  
-rest-client
3  
-sunspot
4  
-
3  .gitignore
... ...
@@ -1,4 +1,5 @@
1 1
 .cookies.lwp
2 2
 .DS_Store
3 3
 /tmp
4  
-*.pid
  4
+*.pid
  5
+vendor/gems
6  Gemfile
... ...
@@ -0,0 +1,6 @@
  1
+gem 'rack', '1.0.1'
  2
+gem 'sinatra', '0.9.4'
  3
+gem 'rdiscount', '1.3.5'
  4
+gem 'rest-client', '1.2.0'
  5
+gem 'sunspot', '0.10.8'
  6
+
3  bin/rackup
... ...
@@ -0,0 +1,3 @@
  1
+#!/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby
  2
+require File.expand_path(File.join(File.dirname(__FILE__), "../vendor/gems/ruby/1.8/environment"))
  3
+load File.expand_path(File.join(File.dirname(__FILE__), "../vendor/gems/ruby/1.8/gems/rack-1.0.1/bin/rackup"))
3  bin/rdiscount
... ...
@@ -0,0 +1,3 @@
  1
+#!/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby
  2
+require File.expand_path(File.join(File.dirname(__FILE__), "../vendor/gems/ruby/1.8/environment"))
  3
+load File.expand_path(File.join(File.dirname(__FILE__), "../vendor/gems/ruby/1.8/gems/rdiscount-1.3.5/bin/rdiscount"))
3  bin/restclient
... ...
@@ -0,0 +1,3 @@
  1
+#!/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby
  2
+require File.expand_path(File.join(File.dirname(__FILE__), "../vendor/gems/ruby/1.8/environment"))
  3
+load File.expand_path(File.join(File.dirname(__FILE__), "../vendor/gems/ruby/1.8/gems/rest-client-1.2.0/bin/restclient"))
3  bin/sunspot-configure-solr
... ...
@@ -0,0 +1,3 @@
  1
+#!/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby
  2
+require File.expand_path(File.join(File.dirname(__FILE__), "../vendor/gems/ruby/1.8/environment"))
  3
+load File.expand_path(File.join(File.dirname(__FILE__), "../vendor/gems/ruby/1.8/gems/sunspot-0.10.8/bin/sunspot-configure-solr"))
3  bin/sunspot-solr
... ...
@@ -0,0 +1,3 @@
  1
+#!/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby
  2
+require File.expand_path(File.join(File.dirname(__FILE__), "../vendor/gems/ruby/1.8/environment"))
  3
+load File.expand_path(File.join(File.dirname(__FILE__), "../vendor/gems/ruby/1.8/gems/sunspot-0.10.8/bin/sunspot-solr"))
3  config.ru
... ...
@@ -1,3 +1,6 @@
  1
+require File.dirname(__FILE__) + '/vendor/gems/environment'
  2
+Bundler.require_env
  3
+
1 4
 require 'docs'
2 5
 
3 6
 run Sinatra::Application

0 notes on commit a5dde4c

Please sign in to comment.
Something went wrong with that request. Please try again.