Permalink
Browse files

* fully supporting pjax-style load of topics

* removed some deprecated and unused dependencies
  • Loading branch information...
1 parent 6fceef5 commit b7a71314daec5bdcc043dcdb58379e3f9f07ec14 @larsburgess larsburgess committed Mar 20, 2012
View
12 Gemfile
@@ -1,19 +1,17 @@
source :gemcutter
gem 'pdfkit'
-gem 'rack', '1.2.1'
-gem 'sinatra', '1.1.2'
+gem 'rack', '~>1.3.0'
+gem 'sinatra', '~>1.3.0'
gem 'rdiscount', '1.6.8'
-gem 'rest-client', '1.2.0'
+gem 'rest-client', '~>1.6.0'
gem 'json'
-gem 'heroku-nav', '~>0'
-#gem "rhomobile-nav", '0.0.35', :require => "rhomobile/nav", :git => "git://github.com/rhomobile/rhomobile-nav.git"
+gem "rack-pjax"
gem 'coderay', '~>0.9.8'
gem 'rack-codehighlighter'
-gem 'shotgun'
gem 'indextank'
-gem 'heroku'
group :development do
+ gem 'shotgun'
gem "rake", '>= 0.9.2'
end
View
@@ -1,47 +1,42 @@
GEM
remote: http://rubygems.org/
specs:
- addressable (2.2.6)
+ addressable (2.2.7)
coderay (0.9.8)
- configuration (1.3.1)
- faraday (0.7.5)
- addressable (~> 2.2.6)
- multipart-post (~> 1.1.3)
- rack (>= 1.1.0, < 2)
- faraday-stack (0.1.3)
- faraday (~> 0.6)
- heroku (1.7.1)
- json_pure (~> 1.2.0)
- launchy (~> 0.3.2)
- rest-client (~> 1.2.0)
- heroku-nav (0.1.24)
- json
- rest-client (>= 1.0)
+ faraday (0.7.6)
+ addressable (~> 2.2)
+ multipart-post (~> 1.1)
+ rack (~> 1.1)
+ faraday-stack (0.1.5)
+ faraday (>= 0.6, < 0.8)
+ hpricot (0.8.6)
indextank (1.0.12)
faraday-stack
yajl-ruby (>= 0.7.7)
- json (1.6.1)
- json_pure (1.2.4)
- launchy (0.3.7)
- configuration (>= 0.0.5)
- rake (>= 0.8.1)
+ json (1.6.5)
mime-types (1.17.2)
- multipart-post (1.1.3)
- nokogiri (1.5.0)
+ multipart-post (1.1.5)
+ nokogiri (1.5.2)
pdfkit (0.5.2)
- rack (1.2.1)
+ rack (1.3.6)
rack-codehighlighter (0.5.0)
nokogiri (>= 1.4.1)
rack (>= 1.0.0)
+ rack-pjax (0.5.9)
+ hpricot (~> 0.8.6)
+ rack (~> 1.3)
+ rack-protection (1.2.0)
+ rack
rake (0.9.2.2)
rdiscount (1.6.8)
- rest-client (1.2.0)
+ rest-client (1.6.7)
mime-types (>= 1.16)
shotgun (0.9)
rack (>= 1.0)
- sinatra (1.1.2)
- rack (~> 1.1)
- tilt (~> 1.2)
+ sinatra (1.3.2)
+ rack (~> 1.3, >= 1.3.6)
+ rack-protection (~> 1.2)
+ tilt (~> 1.3, >= 1.3.3)
tilt (1.3.3)
yajl-ruby (1.1.0)
@@ -50,15 +45,14 @@ PLATFORMS
DEPENDENCIES
coderay (~> 0.9.8)
- heroku
- heroku-nav (~> 0)
indextank
json
pdfkit
- rack (= 1.2.1)
+ rack (~> 1.3.0)
rack-codehighlighter
+ rack-pjax
rake (>= 0.9.2)
rdiscount (= 1.6.8)
- rest-client (= 1.2.0)
+ rest-client (~> 1.6.0)
shotgun
- sinatra (= 1.1.2)
+ sinatra (~> 1.3.0)
View
@@ -3,4 +3,4 @@ require 'bundler/setup'
require './environment'
-run Sinatra::Application
+run Docs.new
View
@@ -34,7 +34,6 @@ edge:
rhoconnect: 'docs/rhoconnect/'
index: 'rhodocs_edge'
pdfkithost: 'edgedocs.rhomobile.com'
- rhonav_host: http://app.staging.rhohub.com
production:
dirs:
rhosync: 'docs/rhosync/'
@@ -46,5 +45,4 @@ production:
rhoconnectjs: 'docs/rhoconnectjs/'
rhoconnect: 'docs/rhoconnect/'
index: 'rhodocs'
- pdfkithost: 'docs.rhomobile.com'
- rhonav_host: https://app.rhohub.com
+ pdfkithost: 'docs.rhomobile.com'
Oops, something went wrong.

0 comments on commit b7a7131

Please sign in to comment.