Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

specify dependencies manually in the Gemfile for now

  • Loading branch information...
commit 81f20c786c67fa6b8aa929dc398851fd2543a764 1 parent b6f3349
@ddollar ddollar authored
Showing with 19 additions and 13 deletions.
  1. +17 −1 Gemfile
  2. +0 −12 Gemfile.lock
  3. +2 −0  config.ru
View
18 Gemfile
@@ -1,7 +1,23 @@
source "http://rubygems.org"
# load the gem's dependencies
-gemspec
+# gemspec
+
+# manually load the gem's dependencies for now until
+# bundler version on Heroku is upgraded
+gem "json", "~> 1.4.6"
+gem "rack", ">= 1.0.1"
+gem "rest-client", ">= 1.4.0", "< 1.7.0"
+gem "sequel", "~> 3.17.0"
+gem "sinatra", "~> 1.0.0"
+gem "sqlite3-ruby", "~> 1.2"
+group :development do
+ gem "bacon"
+ gem "mocha"
+ gem "rack-test"
+ gem "rake"
+ gem "rcov"
+end
# server-specific dependencies
group :server do
View
12 Gemfile.lock
@@ -1,14 +1,3 @@
-PATH
- remote: .
- specs:
- taps (0.3.15)
- json (~> 1.4.6)
- rack (>= 1.0.1)
- rest-client (>= 1.4.0, < 1.7.0)
- sequel (~> 3.17.0)
- sinatra (~> 1.0.0)
- sqlite3-ruby (~> 1.2)
-
GEM
remote: http://rubygems.org/
specs:
@@ -56,5 +45,4 @@ DEPENDENCIES
sequel (~> 3.17.0)
sinatra (~> 1.0.0)
sqlite3-ruby (~> 1.2)
- taps!
thin (> 1.2.0)
View
2  config.ru
@@ -2,7 +2,9 @@ require 'rubygems'
require 'bundler/setup'
require 'extlib'
+$:.unshift File.expand_path("../lib", __FILE__)
require 'taps/config'
+
Taps::Config.taps_database_url = ENV['DATABASE_URL']
Taps::Config.login = ENV['TAPS_LOGIN']
Taps::Config.password = ENV['TAPS_PASSWORD']
Please sign in to comment.
Something went wrong with that request. Please try again.