Add a meaningful error message for probable Ruby version mismatch. #104

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
3 participants

New +1's are added to Issue #92 every other day. While it is hard to really fix it and actually make taps work right with different Ruby versions on client and server, it is easy to add a small message that may save people a lot of time.

This small patch adds an error message that tells the user to switch their Ruby version to 1.9.2 when using the Heroku stacks. It gets displayed when the server response contains the main (only?) symptom of the mismatch, a time zone displacement error.

I feel this would greatly help. Maybe adding a link to RVM could help as well.

Any way to get this merged? Is there any interest? Should anything be changed? This is a huge problem for beginners and a huge time waster for everyone.

webmat commented Jul 31, 2012

Yes! Please take the pragmatic path and merge this in :-) Would have saved me a lot of time!

@rogerbraun rogerbraun closed this Feb 10, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment